+ Start a Discussion
Jon ManloveJon Manlove 

I am unable to complete the Automate Simple Business Processes with Process Builder module

I have tried numerous times to complete this module - Automate Simple Business Processes with Process Builder with no success.  I've tried it in both my trailhead playground and my developers account.  I keep getting the following error message, even after deleting any process associated with contacts/accounts but still no luck.  Any suggestions would be helpful, thanks!

Challenge not yet complete... here's what's wrong:
There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Insert failed. First exception on row 0; first error: FIELD_CUSTOM_VALIDATION_EXCEPTION, Account Number must be 8 characters long.: []

It looks like there a validation enabled at the field level and I don't think it is process builder issue. may be from previous exercise this validation might have been enabled.

By Falcon100 (your valuable click "Solved", will motivate me to help others)
SandhyaSandhya (Salesforce Developers) 

I would suggest you try the challenge in new trailhead playground as there are some pre existing configuration in your org which is preventing you to check challenge.

Please mark it as solved if my reply was helpful, it will make it available
for others as a proper solution.

Best Regards,
Harsha khutafaleHarsha khutafale
I am unable to complete Automate Simple Bussiness Process and Process builder.There are no validation rules set for Contact and i opened new DE.
I am getting below error.Please help.
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: AYMAKZPV
Chris LambChris Lamb
Hi all, please could someone advise me. I'm unable to complete this module, but I have a diiferent error to those above. Thank you

User-added image