function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Malhar Patel PatelMalhar Patel Patel 

Superbadge - Lightning experience reports and dashboard (import data bug?)

There seems to be an import data missing which is required to complete this superbadge.  Fifth bullet under Prework and Notes says, After installing the unmanaged package, navigate to the Data Import tab on the SolarBots app and select Import.  There isn't any link for importing any file?  I was in midst of doing superbadge for reports and dashboard for classic but it expired yesterday.  So I started with this lightning one now, but stuck.
Bedotroyee SarkarBedotroyee Sarkar
If you are navigating to Data Import Tab of SolarBots app, you should see "Import" Button. So just after installing the package, please open SolarBots App and go to the tab and verify. By clicking that button, all the data will be automatically imported.
Malhar Patel PatelMalhar Patel Patel
Your answer is partially correct.  Reason I say partially is because when I installed SuperBot package, there was no Data Import tab.  But when you mentioned go to tab and verify, I decided to reinstall the package and what do you know, now Data Import tab is there.  Thanks for your help.
Bedotroyee SarkarBedotroyee Sarkar
Glad it's working for you now. 
Lisa Zurcher 24Lisa Zurcher 24
I am having trouble with the "DataImportTab"  missing. 1st attempt was in a normal browser window. The result was very odd and the package was not listed in Installed Packages even though the custom Object and App were present. Created a fresh dev org and started over. Opened an incognito browser window in Chrome - verified I was in an incognito window. Installed the package. Package installed and displays in Installed Packages. Open the SolarBots app, there is no "Data Import Tab" in the SolarBots App. I checked to see if the Data Import Tab was hidden - no Data Import Tab available. I checked the Installed Package Components and there is a compenent listed "dataimporttab". I checked the Custom Tabs. There were 2 Tabs installed with the package: SolarBots, and SolarBot Status.... no Data Import.  I uninstalled and reinstalled the unmanaged package and experience the same result. Not off to a good start. Any ideas.. Thank you for any suggestions.   
Lisa Zurcher 24Lisa Zurcher 24
My issue was resolved by creating a Trailhead Playground instead of a new Dev Org. Instructions indicate Trailhead Playground. 
Michelle Brown 32Michelle Brown 32
You need to access the SolarBots app under All Apps on the App Launcher to get the tab. Using an Object from All items on the app launcher wont work. 
Richard Evans 23Richard Evans 23
YES - THANK YOU @Michelle Brown 32:
1) Install App using Incognito
2) Launch App from All Apps (top section) ..... NOT FROM All Items section (bottom section listing all the Objects)
Divya KannayagariDivya Kannayagari
I unistall so many times... to  import the data but i found no data to import can any one help me please
Richard Evans 23Richard Evans 23
The data to import is included with the App and not a file on your computer downloaded separately. If you cannot see the Data Import Tab (a component of the SolrBots App) you are not in the App but direclty accessing the Object. All the  Apps have a small picture in the upper  section in the selection.
Natalie O'ReillyNatalie O'Reilly
H friends! So I created a new Trailhead Playground like it said it to. Then, I installed the unmanaged package. Installation Complete.  The problem I am running into is this - I click on the "App Launcher", and then "SolarBots", then Import.  However, I cannot get through the Import stages.  It will not allow me to click Next.  It will not switch to Edit Mapping stage. What am I doing wrong?
Natalie O'ReillyNatalie O'Reilly
For Step 1 - Do I have to export the data and then import it as a CSV file? It will not let me proceed on the Import screenn to the Edit Mapping step nor click on "Next". I just created my second trailhead playground, but still running into the same issue, and both installations were completed successfully. Both times, I went to the SolarBots app in order to import the SolarBots data. Please help!
Linda KimLinda Kim
@NatalieO'Reilly you aren't exporting data. You are clicking on the data import tab and then import button. Can you take a screenshot of your SolarBots page.
madhavi mishramadhavi mishra
@NatalieO'Reilly, Do you get the solution? I have same problem..Thanks
Hey Madhavi, 
Follow this below attached screen shot. And please mark this answer if this solve your issue.
User-added image
Armando Prieto TrianoArmando Prieto Triano
Solved creating a new PlayGround and reinstalling
Karisma McMahonKarisma McMahon
Hi for anyone having this issue, after installing the Unmanaged Package into your Playground, I've found that the following steps helped me:
(1) Click on the App Launcher (9-circle icon on the top left)
(2) In the Search Bar, type in Solarbots - this will bring up the app (do not click on anything Solarbot related in the Items section with the blue text) 
(3) Click on the Solarbots app - the yellow icon with an owl 
(4) Along the top will be the Data Import Tab that everyone here is talking about :)
Solarbots App under All Apps section, NOT under the All Items section
Hope this helps! :)
Anthony GemondoAnthony Gemondo
User-added image
Could someone help? My SolarBots App doesnt have the "Data Import" tab.
Arjun Singh 63Arjun Singh 63
hi guys,
all of this is to be done in a playground and you'll get the data import option!
worked for me like a charm, it's very frustrating when you are not able to get
through with it but be patient it'll work out eventually.
Sridhar Nanjappaiah 8Sridhar Nanjappaiah 8
I agree with @arjun singh. It works perfect if you go with Trailhead Playground. Give a try with new Playgroud and if it still doesnt work. Please ping on this post and I will respond to it. 
Vineet Jhim 10Vineet Jhim 10
I can see the import button but i am not able to proceed in importing the data as i cant find the CSV file it keeps asking for.
helen spallhelen spall
There isn't a file.  If there is an import button in your solarbot tabs it will pull it through for you.  However there are a lot of issues with people not seeing the right button.  It is often not there even when installed in a trailhead playgound.  I don't even get the account and opportunity tabs let alone the import button.  all of the royutes taking you to the data import wizard and files are noise as people haven't understood the problem that the button for importing is missing.
Shubham Prajapati 47Shubham Prajapati 47
Since the Import Data tab uses a lightning component, you have to enable my domain first for the tab to be visible in your developer account. It works in the playground though as a domain is already enabled for it.
Lee McFarlandLee McFarland


I have the SolarBot installed and have the import button but I keep  getting the following error. 

Any ideas?

SolarBot Data Import

Sunil DhamankarSunil Dhamankar
Hello Friends,
When I press the 'Data Import Tab', I am also facing the same issue and getting the message as being received by Lee McFarland. The details are as follows:

Data Import Issue for Lightning Experience Specialist Super Badge assignment
Deepthi BhumaDeepthi Bhuma
I am getting same error as above and I cancelled warning and its taking longer time to import data. Not sure if data will be imported!!
While Installing the package, select to Rename Conflicting Components in the Package. This resolved my issue. Also I installed for All Users.
Shervone MayesShervone Mayes
For anyone not seeing Data Import tab after installing package:
  1. Click App Launcherapplauncher icon
  2. In Quick Find box type Data Import, then select Data Import
  3. Select Import
  1. Click App Launcherapplauncher icon
  2. In Quick Find box type SolarBots, then select SolarBots. Data Import tab should be visible.
  3. Select Import
Andrea DvorakovaAndrea Dvorakova
Hi guys,

I have the SolarBot installed and have the import button but I keep  getting the following error. 
Was this error fixed? I tried uninstal and instal again with Rename Conflicting Components in Package selected.

But still getting the error after clicking on the Import at Data Import tab.

Sharif PatwarySharif Patwary
Hi Andrea, 

Please check to see if you have any required fields on opportunities, contacts, accounts, etc. The data import is trying to save numerous records but will fail if there are custom required fields (E.g. for me, its was a field named "discount percent" which I've made required as per a previous Trailhead module). 

Furthermore, error logs can be found in Dev. console for the "DataImportTab" lightning component detail - which is what I used to identify the issue. 

Alternatively, you can create a fresh new playground for this superbadge and install the package, etc. 

Hope this helps!