function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Diane ClaytonDiane Clayton 

errors running sfdx plugins:install salesforcedx@latest

I have latest version of salesforce cli and running sfdx plugins --core returns 
@salesforce/plugin-generator 0.0.10 (core)
@salesforce/sfdx-trust 1.0.8 (core)
builtins 1.0.0 (core)
salesforcedx 43.12.0 (core)

But  when I run  sfdx plugins:install salesforcedx@latest I get errors below:
Installing plugin salesforcedx...
Installing plugin salesforcedx... Checking for digital signature.
Successfully validated digital signature for salesforcedx.
Finished digital signature check. Installing... !
 !    yarn --non-interactive --mutex=file:C:\...\AppData\Local\sfdx\yarn
 !    --cache-folder=C:\Users\...\Local\sfdx\yarn exited with code 1
 !    warning salesforcedx > salesforce-alm > replace > minimatch@0.2.14: Please update to minimatch
 !    3.0.2 or higher to avoid a RegExp DoS issue
 !    warning salesforcedx > force-language-services > salesforce-alm > webdriverio > archiver > glob >
 !    minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
 !    warning salesforcedx > salesforce-alm > replace > nomnom@1.6.2: Package no longer supported.
 !    Contact for more info.
 !    warning salesforcedx > force-language-services > salesforce-alm > webdriverio > request >
 !    node-uuid@1.4.8: Use uuid module instead
 !    warning salesforcedx > salesforce-alm > jsonwebtoken > joi > hoek@2.16.3: The major version is no
 !    longer supported. Please update to 4.x or newer
 !    warning salesforcedx > force-language-services > salesforce-alm > webdriverio > request > hawk >
 !    hoek@0.9.1: The major version is no longer supported. Please update to 4.x or newer
 !    error An unexpected error occurred: "
 !    Request failed \"503 Service Unavailable\""

Even I was getting error........May be because of Office LAN(Some proxy as pointed out some of the developers). Later on I tried on home network... and it worked for me. Wanna to hear other's story.


I am also getting same error
sfdx info:
@salesforce/plugin-generator 1.0.1 (core)
@salesforce/sfdx-trust 1.0.8 (core)
builtins 1.0.0 (core)
salesforcedx 44.18.1 (core)
I have found the solution. This issue was due to issuer certificate. After digging up I found following error: Trace: 
  Error: unable to get local issuer certificate
      at TLSSocket.<anonymous> (_tls_wrap.js:1103:38)
      at emitNone (events.js:106:13)
      at TLSSocket.emit (events.js:208:7)
      at TLSSocket._finishInit (_tls_wrap.js:637:8)
      at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:467:38)

Steps to resolve the issue: 
  1. Install the yarn package:
  2. open the CMD (if already open than close and open it again) and go to the AppData\Local\sfdx\plugins folder (in my case cd D:\Users\Varun Rajpoot\AppData\Local\sfdx\plugins)
  3. Execute the following commands: 
    1. yarn install
    2. yarn config set strict-ssl false
  4. Now install the pre-release package sfdx plugins:install salesforcedx@pre-release
  5. f successfully installed check by running sfdx plugins command( output: salesforcedx 45.0.12 (pre-release)) 
Varun Rajpoot
Diane Clayton 9Diane Clayton 9
It was a corporate network issue. I switched off the corporate network and it worked.