function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Christine Pallen 12Christine Pallen 12 

Superbadge: Business Administration Specialist - Challenge #1

Hello - I am working on the Superbadge for Business Aministration Specialist and on Challenge #1 I get an error saying " All Accounts must have a type".  When I import them, they all have a type and I set up the picklist value correctly.

I've spent too much time trying to figure this out...I've read other posts on this and I've checked all the boxes for what will solve it and none of it works. Help!
NagendraNagendra (Salesforce Developers) 
Hi Christine,

Sorry for this issue you are facing.

May I suggest you please download and make changes to the import file. Open it in a program of your choosing (Notepad ++, MS Excel, OpenOffice Calc – this one is my favorite for CSV files), look for any duplicate, change the upper case Account Names to the normal case and fill any empty Type values with Residential. Your file should look similar to the one on the picture below just before the import.

User-added image

Before importing, navigate to the Type field on the Account object and add the value Residential to this picklist. To import the data, you can use After login, on the top of the screen click on New Task button and select Import. Then select Account object, upload the csv file and load the data. Easy!Challenge

You are now ready to check the first challenge. Good luck!

Hope this helps.

Deepthi T 28Deepthi T 28

I installed the unmanaged package.I modified and imported data.I am not able to clear the trialhead.Please check below screen shot.

User-added image

Sacsu sunSacsu sun
Hi Christine,

Have you found a solution, How did you do?
Kristina DillonKristina Dillon
I encountered this error by uploading the data before I added the new value for the picklist Type.  If there is no matching value, it will not populate that field.
Joshua WheatJoshua Wheat
I have the error: Challenge Not yet complete... here's what's wrong:
All accounts must have a type.  
Every account has a type, (at least from all accounts page 23 accounts in total, as some come with developer addition), I have changed sForce to a Customer XX acount. I also tried deleting it (multiple different playgrounds). I have manually gone through on every account and physically redid the picklist (and before it is asked yes I added Residential). I have created validation rules to raise errors if blanks are put in. I have spent 4 hours on one step, specifically four hours on one part of the step. I have verified imports with multiple different imports and types of imports, as well as verified the data being imported had no duplicates and was correct. I have verified packages were installed correctly in the correct order. I am out of options. each option afore mentioned I verified and checked to see if the challenge was complete. I believe it is a different error for if you fail to add the picklist or install packages incorrectly/ have incorrect names on the accounts. I can verify there were no caps lock data on my import. I have also manually gone in and made all account types required in page layouts.

Please help, the reason that was so long was to limit comments of things already tried.
Hi All

I am fairly new to Salesforce as I am looking to become a future admiistrator so I am also completing the badges.

In regards to this thread I also received the error.

What I observed was that while the data was imported and imported successfully using dataloader. The "All accounts must have a type" still populated.

I observed that under the "Account Object" and Fields and Relationships field "Type" that the "Residential" item within the picklist wasn't in the "Active section". Not sure why, but once this is re-activated this error will resolve.

Let me know if this assists and like the answer if this does.


Shaun Emmett