function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Michelle Daniels 11Michelle Daniels 11 

Create a Chat Snap-in---trying to create a new CORS and it won't save

I'm working on the Trailhead "Build a Community with Knowledge and Chat" because I really want to learn how to use the Chat Snap ins for communitites. I'm getting stuck on the "Create a Chat Snap-in" section. It says to go to the Visualforce pages and copy just the beginning of the address which is So I am copying Then it says to create a new CORS with this copied address. However, when I copy this into the new CORS original URL pattern then it will not save. Can anyone tell me what I am doing wrong? I can't move forward without this step and I really want to learn how to do this. Thank you!
Best Answer chosen by Michelle Daniels 11
Bhavishya MoolyaBhavishya Moolya
Hey Michelle,

I tried using chrome browser to create the new CORS, it worked for me. I think browser was the issue with this unit.  

All Answers

Bhavishya MoolyaBhavishya Moolya
The same thing happened to me when I was working on this module. I tried multiple times but no luck in creating the new CORS Whitelist, the address is not getting saved there.

What about you? Did you try again? Did it work?
Bhavishya MoolyaBhavishya Moolya
Hey Michelle,

I tried using chrome browser to create the new CORS, it worked for me. I think browser was the issue with this unit.  
This was selected as the best answer
Michelle Daniels 11Michelle Daniels 11
THANK YOU Bhavishya Moolya! This worked for me! I really need to start using chrome as my default. Really appreciate your help...I was so stumped why it wasn't saving. Have a good week!
Bhavishya MoolyaBhavishya Moolya
It's absolutely my pleasure! And glad to hear that it worked. "Normally, browsers enforce Same Origin policy, to guard against attacks such as cross-site request forgery (CSRF). CORS (Cross-Origin Resource Sharing) loosens the browser Same Origin policy in a controlled manner". So in this case, that could be a reason why Safari browser/other browser was preventing the creation of new "CORS". 

You too have a wonderful week ahead! :) :)
Claudio Bruno 8Claudio Bruno 8
Thank you Bhavishya Moolya, your solution works.
Blair ColeBlair Cole
Microsoft Edge browser has the same issue, thanks for the solution!
Gowri KaranamGowri Karanam
I am stuck in this challenge. I am unable to find snap-ins from the setup on lightning or in calssic. can anyone please help?
David Cuthbert 6David Cuthbert 6
Hi, I am using chrome and I was able to save the CORS. I get this error msg when I click the Snap-ins link: 'Please contact your administrator for snap-in setup: 1970204174-86999 (-1175438338)'

Michelle HermansenMichelle Hermansen
I am unable to find Snap-Ins in Setup in Lightning as well. Did I miss a step?
Raul Martin DiazRaul Martin Diaz
It is possible that you do not have the live agent activated
Blair ColeBlair Cole
I didn't check thread...just responding to your email alert....What browser are you using?
Raul Martin DiazRaul Martin Diaz
Google Chrome
Bhavishya MoolyaBhavishya Moolya
Did you try another browser. Also. try clearing browsing data, cookie, cache, etc. See if that works. 
Sankhadeep  BiswasSankhadeep Biswas
Im also getting an error like Please contact your administrator for snap-in setup: 1068744594-242507 (2091850395) while setup Snap-ins
Marla MartinMarla Martin
Thanks for the post! I had the same issue in Chrome, but after reading you post, I tried it in Firefox and it worked like a charm. 
Force ExplorerForce Explorer
@Bhavishya Moolya  wondering  if you can help with this error.    Have created  a Post Chat  Survey which is a VF Page.  Put  the Post Chat Survey isn't coming up( Blank)  when the Snap-In User click Feedback. Wondering  if this anything to do with CORS . Below is the link I have posted in the SF Communities
M.E. 10M.E. 10
I can affirm that switching from Microsoft Edge to Chrome immediately solved the problem of the CORS not saving. Thank you!
Seth Vanderdrift 6Seth Vanderdrift 6
As of 2019-03-26, I'm unable to get the URL to save when using Safari 12.0.3 on MacOS
Using Chrome to make the CORS entry worked.
Pranav Kulkarni 12Pranav Kulkarni 12
Thank you Bhavishya Moolya, I was trying to complete the same module from Microsft edge but everytime end up with no results. It did help me to complete the module with Google Chrome.