function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Nicodemus MooreNicodemus Moore 

Schema Builder Text Area Issues

Keep getting the following:  Challenge Not yet complete... here's what's wrong:
The field 'Street_Address__c' either does not exists on the Property__c object or it is not of type textarea. 

Not sure why though.  I clearly dragged "text area" over to "property".  See pic below for verification.  Any help would be appreciated.  Thanks!

User-added image
Rahul KumarRahul Kumar (Salesforce Developers) 
Hi Nicodemus Moore, Hope it will be helpful.

Please mark it as the best answer if the information is informative.

Rahul Kumar
sure 36sure 36
I have the same problem ,I have checked it more than 10 times ,its the same error again

Work with schema builder

Challenge Not yet complete... here's what's wrong: 
The field 'Street_Address__c' either does not exists on the Property__c object or it is not of type textarea.

I have completed all the steps listed but still getting this same result. Any ideas?

please some one help me

Nicodemus MooreNicodemus Moore
I never figured out the problem and couldn't get any support from Salesforce so I just logged out and never went back. Haven't looked at it in months. Sorry.
sure 36sure 36
Thanks ...then I think its problem with salesforce team...they should notice it and solve it as soon as possible....hope so...
Bruno AckerBruno Acker
I'm working on it for hours ! Thanks to god, I found this conversation
Sarath Chandra 53Sarath Chandra 53
I have the same issue with the same field. I hope it gets addressed soon by salesforce. 

error: Challenge Not yet complete... here's what's wrong: 
The field 'Street_Address__c' either does not exists on the Property__c object or it is not of type textarea.
Raul EustaquioRaul Eustaquio
Simplemente tienes que crear el campo en el Objeto Propiedad! SI relacionarla.
Ayesha AkalooAyesha Akaloo
So glad i'm not the only one facing this problem. Tried a few times and still no luck. I will report and see if we can get a resolution
Sarath Chandra 53Sarath Chandra 53
Hi team,
I've just retried using my Dev Org instead of Trailhead play ground and i was able to complete the challenge.
you may try the same work around and revert if that helped. 
Not sure why the challenge did not work using TH but went fine with Dev Org. 
Ayesha AkalooAyesha Akaloo
Great idea, thanks!
Bruno AckerBruno Acker
Hi there, I'm using the trailhead. Unfortunately, I forgot my password and when i linked for a new login password, i need to answer the city where i was born. I can't remember the answer i put. Can you unlock my account : ? Best regards, Bruno
aieman Alnamahaieman Alnamah
you have to drag the Text Area and add Field Label name which is Street Address :D
aieman Alnamahaieman Alnamah
I hope the picture helps you have to drag the Text Area from the Element and in the Field Label add Street Address :D and your problem will solve.
Eduardo CorderoEduardo Cordero
SOLVED!! ... just drag the Property Object (the one that is there by DEFAULT, not the one we created all along the practice), and add the text area field from the Elemet list
Noman AhmedNoman Ahmed
The above picture solve the problem.
Max Figueroa 11Max Figueroa 11
For me the problem was that the API name for Property was set as Properties__c instead of Property__c. I edited the API name and then re-checked and I got the badge. I hope that helps someone.
shehmeer Malikshehmeer Malik
I had the same problem, could not drag any the field in the 'property' object. when I changed my setup to lightening experience, it was dragged easily. Make sure you are working on lightening experience to complete this challenge as it is designed on lightening experience. Thanks
Alejandro RojasAlejandro Rojas
SOLUCIONADO!!!!! Verifiquen el nombre de la API

User-added image
Unfortunately for me still does not work.. I have checked and tried all above you proposed here...
Imene HakemImene Hakem
I  worked for me:
  1. -Open different  Trailhead Playground (Not the same where you have done your challenges)
  2. Create only "Proprety" Object then add the field "Street Name".
heta p 2heta p 2
Hi All,
I just completed this challange by requesting a completely new Trailhead playground. do not use used TH or your Dev org. solve an  entire module challanges  in a completely new TH playground. once you done close all tabs and launch it again.

Please mark it as the best answer if the information is informative.


Jignesh Panchal 25Jignesh Panchal 25
I got the Solution for this. User-added image
You have to update the object name field from properties to Propety only,. Good Luck 
Vincent HawleyVincent Hawley
So make sure you put it in as TEXTAREA not as just plain text. That makes the main difference because it will not read it as just TEXT
Corentin DixmierCorentin Dixmier
Most of the problems are because you did not write the correct Field Name, in this case it is because you probably forget the _ between Street and Address. You have to make sure you wrote in Field Name: "Street_Address" and not "Street Address"
Mohamed AkramMohamed Akram

To complete this challenege, there is a one easy way

you have to do,just create another object using schema builder or create custom object option and name it as a property, its a duplicate object with same name (that is not an issue).
Then just drag and drop text area and name it as street address
Now it would be done and dusted

your challenge completed

Zach VowlesZach Vowles
I had this same issue, I fixed it by deleting the object from the schema builder and remaking it through object manager (that was covered in the previous module).
scott chappellscott chappell
My issue is with the Data Modeling hands-on challenge part 1 Data Modeling Hands-on challenge part 1 - Challenge not yet complete in My Trailhead Playground 1 Could not find a custom object 'Offer__c'
Abang Irfan Abang Abdul HalilAbang Irfan Abang Abdul Halil
I have found out that i pick text, instead of Text Area. Because you want end user to input the street address, duh 😅
Islam Elegiry 2Islam Elegiry 2
finallllyyyyyyyyyyyy i made it
finallyyyyy i passed it
I created another trailhead playground then I created a new object "property" on the new playground then I created the street address field on schema then I checked the challenge 
Kamal Mohammed Seghir 1Kamal Mohammed Seghir 1
You need to change Api nam of Property User-added image
RJ R 1RJ R 1
I confim, adding one underscore after" Property" label did it for me. 
The api name now shows Property__c which is what trailhead was testing.
User-added image
archana radadiaarchana radadia
I wasted my 5 hours seeing same error, I wanted to solve it anyhow.  did all trials,
what worked for me- create new playground, create property object in schema builder (delete from object builder if you already have it), then place field on property object that you created on schema builder. make sure spelling of street address is right.
all the best!