function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Carl O'Bryant 4Carl O'Bryant 4 

Stuck in Trailhead - Enable Salesforce Knowledge

I'm getting the following error when Checking the challenge for the Enable Salesforce Knowledge component of the Knowledge Basics module in Trailhead even though everything is set up correctly according to the article. Knowledge is enabled, the language is set and the user has the appropriate permission. What am I missing?

User-added image
User-added image
User-added image
Hello Carl O'Bryant 4,
Please follow below steps .....

step 1. Go to Setup
step 2. click on Manage user (Select User).
step 3. Select Syatem Administrater.
step 4. Click on Edit----->  Knowledge User(enable the check box) and click on save.
Step 5. IN quick search box type Knowledge settings and click on check box yes.
step 6. Check your chalenge in trail head

And let me know it is helpful or not ...

Thanks & Regards 
Gopal M.
Carl O'Bryant 4Carl O'Bryant 4
Hi Gopal,

Unfortunately this is not working - all of these settings are already completed correctly however Trailhead doesn't seem to be recognizing the correct setup. If you see in my original screenshots the Knowledge User checkbox is already checked in the user record and the 3rd screenshot is only available after Knowledge has been enabled. 

This would be badge #35 for me so starting with a new DE is not really an option for me at this point.

Please let me know how to resolve this!


Hello -C,

I follow the same steps, i cleared the chalenge..for it's working fine.
Try for  anthoer org...

Thanks & Regards 
Gopal MUser-added image 
Nierrbhayy PatelNierrbhayy Patel
Hi Gopal,

Same is not working for me. Can it be because I had activated lightning knowledge already before taking this course? I have cleared the next units but this one is still pending and throwing me the same error.

Maximilian SpettelMaximilian Spettel

Hey, same happened to me and my colleague. We activated knowledge before at a campfire. 
we do all the steps but lightning knowledge cannot be found in the qickmenu (or anywhere else :()
Please help



Maximilian SpettelMaximilian Spettel
Found the error, need to switch back to classic to find knowledge
Ryan ChisholmRyan Chisholm
I just ran into the same issue where I had enabled knowledge prior to starting the trail badge. Tried troubleshooting by: 
- logging out and back in within both dev org and trailhead.
- Switching to Lightning and back to classic
- Changing other checkbox settings off then on.
- changing languages from english to german and back.

nothing is working.  Any help would be appreciated.
Andy KulkarniAndy Kulkarni
Me too ran in the same issue for same module. Also facing issues for next module:
Trailhead Knowledge Module Issue
Ty WhitfieldTy Whitfield
I'm having the same issue.  I was even able to go to the next section and create an article and pass that.  When I come back to this section, it still gives me the error.  Which is odd considering that I just created an article.
Nagendra Ananda 17Nagendra Ananda 17
Hello All- Me too facing the same issue, any help is appreciated.

Will BissettWill Bissett
I had this problem too; all was set up correctly in my standard DE (which I've been using for nearly 3 years and enabled Knowledge on not longer after setting up), but got the error message above.  I resolved it by using another Trailhead playground, setting up Knowledge and doing the Trailhead Check.  If you don't have another playground then spin one up - you'll almost certainly need it at some point anyway.  
Steven PayneSteven Payne
Will Bissett's solution worked for me. I just repeated the module in a different playground and it worked fine. I was getting all the same errors in the playground I use by default for most trailhead modules.