function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Justin MurtyJustin Murty 

Get Started with the Salesforce Platform - Install the Dreamhouse App

On the App Launcher tab of my developer org, it's not showing the Dreamhouse App I installed even though I followed all the instructions in the Trailhead instructions in the Getting Started with SalesForce Platform module. I have since seen that there are two possible versions of DreamHouse to launch but I'm not sure how to proceed since the Trailhead instructions has lead to installing a version of of Dreamhouse I'm not seeing on my org. Does anyone know how to proceed so I can complete this Trailhead session?
NagendraNagendra (Salesforce Developers) 
Hi Justin,

Sorry for this issue you are encountering.

Please make sure that you are installing the dream house app by clicking on the second link which is for summer17.

Still, if the problem persists please double check that you are connected to the correct developer edition with your trailhead.

May I also request you please confirm whether you are validating the challenge in trailhead playground or a developer edition org?

Please let us know if you have any further queries.

Hi Justin,
Follow some given steps:
In Hands-on Challenge
  • Change the org name as 'Create a Trailhead Playground' and Click on Launch.
User-added image
  • Replace everything after with /packagingSetupUI/
User-added image
  • Select - Install for All Users and Click on Install.
User-added image
  • Checked the 'Checkbox' and Continue.
  • After the installation click on 'Done'.
  • Click On the Icon of the Setup (App Launcher), From the Left-Top Corner.
User-added image
  • Select DreamHouse
  • Select Data Import Tabs and click on 'Initialize Sample Data'.
User-added image
  • After that you will get an alert message, Click on Ok button.
Now, Check Challenge.

I hope it will help you!!
If this answers your query please mark this question as a solved so that it can be filtered out from unsolved questions.
Justin MurtyJustin Murty
I went through pretty much all these instructions. The only thing was when I went to launch my trailhead playground, there was no part of the url that stated There was however, a part of the url that stated, so I just edited the link after that point. Everything else proceeded as normal until I didn't see the dreamhouse app in my app launcher and the challenge wouldn't success even after initializing the sample data.
User-added image

User-added image

When I accessed the Trailhead again today, I got the same URL's and App Launcher options as the screenshot. But with the Dreamhouse App showing on the Installed Packages page, checking the Trailhead again finally displayed a success even though I didn't end up doing anything different from yesterday. Basically there were a couple spots were I expected to see something different than what I was expecting based on the instructions.
Dave Pattison 6Dave Pattison 6
I have exactly the same results as above. Installed the Dreamhouse App 'for all users' successfully, but there is no way to launch it.  
In the list of Apps in Setup, there is no entry for Dreamhouse. There is an installed package called Dreamhouse.
Dave Pattison 6Dave Pattison 6
So I then found I had to switch on 'Lightning Experience' in the Trailhead Playground org. The Trailhead module ("Get Started with the Salesforce Platform") said nothing about that.
Justin MurtyJustin Murty
Yeah, I had to play around with it a little to get around this hiccup. I was eventually able to get it, I just ended up with some additional baggage beforehand.
Carolyn Vance 5Carolyn Vance 5
I'm stuck on this one, too.  I've tried using the 'Install the Dreamhouse app package' in your Trailhead Playground link, and it installed Trailhead Project 1.0.  I tried changing the link to the one listed above ending in UeX, and it installed (once I uninstalled the Trailhead Project 1.0 package) an unmanaged project. Either way, the challenge didn't verify. I have just one Trailhead playground, and that's where it's getting installed and showing up as installed.  I tried switching on Lightning Experience, and installing it via an incognito browser window.... any other ideas?  Seems like it should be as simple as clicking on the link in the Trailhead module. 
Andrew SchroederAndrew Schroeder
Hi all: Yeah, I'm completely stuck on this, as well. When I click on the link to install the DreamHouse app package and click on Install, I keep getting some sort of error about Apex Classes. Specifically, part of the error reads: "Installing this package requires the following feature and its associated permissions: Apex Classes" As a rookie, I have no idea what that is or how to progress past it. I'm frustrated that I'm this lost and it's only the beginning, so any help is appreciated. 
Success!  Here's what I did.
  1. From the lesson, 'Create New Playground' and then launched it.
  2. Enabled Lightning Experience in the playground.
  3. Clicked on 'setup', searched for 'users', ticked my name and reset my password. (If you're getting lost as to which e-mail address you have with what on SalesForce, look at your user page first to make sure you know where the password reset link will go.)
  4. Set up a new password for myself.
  5. Used the link in the challenge - but opened it in a Private/Incognito window.  (Here's where having the password comes in handy.  And you don't get the password for your playground until you reset it as an admin.) 
  6. Installed for all users.
  7. Check challenge .
  8. Phew!
Andrew SchroederAndrew Schroeder
It's not working. What is driving me batty is when I launch the playground, it opens a new window and at the top of the new page, it says, very plainly, DreamHouse. How the heck can the playground open in Dreamhouse and then Trailheads say that I don't have it installed. And, I'm sorry, but in step 3,  clicked on Setup, and then Users on the right side of the page, and didn't see anything like you were discribing. AAARGH!
Aaaargh is right.  Here's a modified Step 3...
Click on the gear icon at the top right, select Setup
 That brings me to this in the top left:
SetUp Menu, upper left corner

Click Users, and there’s an expanded menu.  That expanded menu has ‘Users’ as an option. Click that, and you'll get to a screen that looks in part like this (with more users).  Tick the square next to your name, and then you can reset your password. 
User-added image
You can also look at your record first - see what e-mail the password reset email will go to.  There's an option to change your password on that screen, too, but it's only helpful if you know what your current password is.

Robert OatmanRobert Oatman
Sorry - same issue here. I have created multiple playground orgs - and installed the package multiple times. Passwords reset, etc. - it simply cannot validate that the package was installed.
Bambi FellowsBambi Fellows
i have rhe exact same issue.. how can i finish the trails directly within the dev account without having to create playgrounds?
Andrew SchroederAndrew Schroeder
Nope. Still not working. I changed my password and I opened the link in the challenge in an incognito window and I keep getting the same error merssage. Something about Apex Classes? I can't believe this is that difficult. 
Bambi FellowsBambi Fellows
me too. and when i supposedly  need to create another field in currency  called Prequalified Amount according to a post from SF..  still does not see it.. and still errors..logged in out, cleared cookies.. someone please HELP? Thank you.. i got it to work on the dev account once instead of TP..but now its not seeing the points anymore?
Jen DunnJen Dunn
Mine installed fine, but when I go to the properties tab to look at a properties record, I get the following error:
Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. Error ID: 2143186700-47216 (473429469)

Anyone at salesforce looking at these comments?
Samir Sayyad 25Samir Sayyad 25

Thank you Akshay Dhiman. It worked. It was really helpful. 

Ana Karen HernandezAna Karen Hernandez
Hello! I keep finding myself with this error over and over agaaaain! I´ve created several playground and keep getting it!! do you know what do I have to do?

User-added image
Bruce HolemanBruce Holeman
Akshay_Dhiman's answer worked for me.
Vinu Chandran VVinu Chandran V
Thanks Akshay_Dhiman. This has solved my problem.
Abhimanyu Tyagi 9Abhimanyu Tyagi 9
For me the problem turned out to be the fact that I was using SalesForce classic. After switching to lightning I could see the dreamhouse app and follow the instructions to finish the challenge.
Louise GriceLouise Grice
After several attempts at downloading and multiple Playground's, I was still not able to see the Initialize sample data in Data Import tab, which is needed to complete the challenge. I figured out it was my browser setings - I had third party cookies blocked - once I unblocked the Initialize settings displayed under the tab. I'd recommend all chrome users to make sure they are not blocking cookies in     "chrome://settings/content/cookies"
Good luck in this challenge everyone

Maciej PitakMaciej Pitak
I had the same issue using Google Chrome.

Possible workaround (worked for me):
1. Open a trailhead page with this lecture in Internet Explorer
2. Launch the playground and verify the challenge in Internet Explorer

Voila. Let us know if it worked for someone.
Ana Karen HernandezAna Karen Hernandez
It worked for me using IE :)
Bernadette BuckBernadette Buck
I had the same issue where I could install DreamHouse fine in my fresh Trailhead playground but the challenge was not accepted; I received the message "DreamHouse does not appear to be installed." In my case I had other Trailhead playgrounds. When I did the steps in my default Trailhead playground instead, the challenge was accepted. You can see which one is your default if you select "Manage my hands-on orgs" in the dropdown to the left of the Launch button. I haven't tried changing the default to see if that works instead.
Tomáš KubešTomáš Kubeš
I finally resolved the issue.

I created a new playground as it was said "You need to use a fresh and clean Trailhead Playground for this module." But the checking procedure was checking the first playground even if the second was selected in the Combox. So I have to swithc back to playground 1 and reset Dreamouse data in Playgorund1.
Marek SobczakMarek Sobczak
At least for me.
Just before pressing Launch, make your brand new Playground to be Default.
Milan Jovanovic 2Milan Jovanovic 2
Simillar to Louise Grice report, I had a problem with import with firefox, I had to turn off blocking of cookies and trackers for import to work.
Nikhil Goud 2Nikhil Goud 2
how to install dream house
Tanie BluesTanie Blues

Thanks Akshay_Dhiman. 

Initialize sample data WORKED!

User-added image