+ Start a Discussion
vlrvlr 

Disabling TLS 1.0 and old php version for soap client

Given:

1.Windows Server 2008 R2
2.PHP 5.3.10
3.OpenSSL/0.9.8t
4.Salesforce disabling TLS 1.0
5.Legacy app which I did not write.

We are only using php to use Soapclient to connect to Salesforce and to process some csv files. It does not run on any server. This app is started by windows scheduler after csv files are uploaded to that machine. I need at least OpenSSL 1.0.1 or higher for TLS1.1.
What are my fastest options? Can I link OpenSSL/1.0.1 to PHP 5:3:10, and how to do it?
Or, should I start moving that app to latest PHP version ?
NagendraNagendra (Salesforce Developers) 
Hi,

In theory, you should be able to install PHP 5.6, update OpenSSL to 1.0.1, and everything should work. However, that's just a theory, and may or may not work in practice, so you might want to try this out on a dev server before you commit to doing this in production.

Hope this helps.

Thanks,
Nagendra