function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Mars Rover 405Mars Rover 405 

Error in Set Up Weather Company Data Service on IBM Bluemix

I can't progress pass the first stage on this project.  I get the error: Could not authenticate with the IBM Bluemix service. Please validate your credentials (also below).  Please can anyone help?

User-added image
Brian KesslerBrian Kessler
I'm having exactly the same problem.
First I tried with a developer org (which interestingly enough, I also renamed to "Mars Rover").
Then I tried with a trailhead playground.

I also tried changing my password to ensure I was typing it correctly.

Nothing helps.  :-(

Mars Rover 405Mars Rover 405
Hi Brian, I managed to do this in the end.  I deleted the organization I'd created and started again.  I used all the suggestions on the Trailhead page, e.g. US South for region and dev for the space.  At some point I think I was in the wrong space (in the top right corner), so corrected it, although I'm not sure if that was the issue. Good luck :)
Brian KesslerBrian Kessler
Ah... I figured it out... Misread the instructions and was using the wrong username/password.
Sometimes I think too literally.
Shrutika Vithalkar 16Shrutika Vithalkar 16
I followed the instructions given in trailhead.
Getting this error.
User-added image

Any idea,what am I missing ?

Prakash Rai 7Prakash Rai 7
From IBM Cloud, Service Credentials, click View Credentials for Credential-1 and then copy paste URL, username and password. 
Matt SheaMatt Shea

I am receiving similar error messages as the previous messages above.  I have reviewed the credentials.  Has anything changed with this challenge in the last year?  I've placed the host in the URL, the username and password appropriately ( I think).



To borrow from a prior post, What am I missing?

Thanks in advance for any assistance,

Land JohnstonLand Johnston
I'm also getting the same exact error. Copy and pasted the URL, username and password several times and keep getting the same error. Very frustrating as I need to figure out how to implement this in my day job.  
Teo PopaTeo Popa
I also received this error over and over until I finally deleted my Weather Company Service in IBM Cloud and recreated. When I recreated it, I made sure to delete the two characters added to the right of the name i.e Weather-Company-Data-p7 became just Weather-Company-Data, I selected Location=Dallas, Org=my email (IBM username), Space=Dev. Then from the Credential JSON file, you only use the username and password (without the quotes), but not the long URL. URL for the named credential is just