function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Tejender Mohan 9Tejender Mohan 9 

How to delete approval process on Goal Object ?

For test purpose i have created an approval process on goal object but now i am not able to delete it.
Can someone please suggest some solution .

Below is the errror  (getting same error on 2 of my dev org while deleting approval process of Goal Object )

An internal server error has occurred
An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience. 

Thank you again for your patience and assistance. And thanks for using! 
Rahul KumarRahul Kumar (Salesforce Developers) 
Hi Tejender Mohan,

 You will be able to only delete the approval process if you delete all those records and empty the recycle bin.

Sometimes even if all records that are using the approval process in question are deleted, you still might not be able to delete the approval process.

The reason for this is that emptying the recycle bin does not mean that the record still doesn't exist in the database. There is a process called "PhysicalDelete" that comes along and deletes all records that have been soft-deleted but no longer exist in the recycle bin. This process typically runs on the weekend.

After the weekend, you should have tried to delete the approval process again, when the recycle bin is cleaned up permanently.

Please refer the below link for reference. hope it will be helpful.

Please mark it as best answer if the information is that question is removed from an unanswered question and appear as a proper solution.

Rahul Kumar
Tejender Mohan 9Tejender Mohan 9
Hi Rahul,

I waited for the weekend and
today I have tried to delete the approval process but it is still not removeble with same error message.
any suggestions ?