+ Start a Discussion
Josh HovelnJosh Hoveln 

Quip Lightning Component Not Showing

Going through the trailhead to install Quip in my DE and when I go to add the custom component to the leads layout it does not show up in the list of components. I've installed the Quip for Salesforce App from the App Exchange. Has anyone else seen this? 
Ben FuquaBen Fuqua
I am running into this as well. I got credit for completing the challenge when adding the component, but in the subsequent task where you have to actually use the component on the Lead Record page, it does not appear. Going into the Edit Page screen, however, the Quip component shows up with the message stating "Insufficient permissions to display this component". 

User-added image
Ben FuquaBen Fuqua
OK, figured it out. There are actually two different Quip components. There is "Quip" which is what I tried to install and what was causing the problem. And, there's Quip Documents, which is all the way down at the bottom of the list. That's the one you want and that's the one that works. 

User-added image
Ken Holley 5Ken Holley 5
well that was obviouos .... not - thanks for recording the answer
Shanti Ariker 8Shanti Ariker 8
I did the same thing but only  Quip shows up in mine, not quip documents.  I can't figure out how to do it any differently. Any ideas?
Matthew Hauck 15Matthew Hauck 15
I have the same problem but no quip documents - my trial account is not setup as business account, I don't think we can use quip in trailhead with a trial and finish these tasks
Thiago LealThiago Leal
Same problem here... Did anyone solve this?

User-added image
LAM Jean PaulLAM Jean Paul
Same problem, any feedback ? 
Justin Feldman 7Justin Feldman 7
@Thiago Leal and @LAM Jean Paul, as per one of the previous answers:
  1. Enable myDomain
  2. Edit the lightning record page
  3. Scroll down to "Custom Lightning Components"
  4. Use the Quip component listed there, called "Quip Documents". User-added image
Midles SmithMidles Smith
for me, this thread solution worked  https://salesforce.stackexchange.com/questions/164931/is-there-a-way-to-call-javascript-after-action-on-visualforce-page
https://www.ucbrowser.vip/ https://shareit.onl/ https://mxplayer.pro/