function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Robyne VaughnRobyne Vaughn 

can't finish my challenge because it won't let me log in to app exchange

in the module:  Extend Your Reporting Strategy with AppExchange.  I launched my trailhead, went to settings, opened app exchange, picked an app, selected "get it now", then was presented with screen saying I needed to log in.  I clicked something like "open log-in screen" and get a spinning wheel.  Have tried different scenarios of this, inluding opening in new tab, but nothing works.  I may get a log-in opportunity by opening in new tab, but when I do, it doesn't recognize my login credentials.  I click "reset password" and it never emails me.
Debra UDebra U
I am having the same problem ... cannot finish challenge - I cannot log in to app exchange.  Anyone have any suggestions?
Debra UDebra U
@Robyne Vaughn - Hi Robyne - were you ever able to log in to the App Exchange?  Were you able to complete the module?  I'm still stuck and have not received an answer to the issue yet.  Hoping you can help?
Robyne VaughnRobyne Vaughn
No, sorry. I started another module instead of waiting idly. Meanwhile, my trial subscription ended(which I signed up for initially) and that forced my developer version (which I acquired after my trial subscription) to end as well (same gmail username), so I'm waiting on support to reconnect me to my developer account . Best wishes for your success. Robyne
Debra UDebra U
@Robin Vaughn - Good Morning!  I wanted to let you know that I was able to get in to the AppExchange and complete the challenge by going directyly to  From there I was able to download the apps needed to complete challenge and earn the badge.  Good Luck!
Robyne VaughnRobyne Vaughn
Good! Thanks
Tara MelcherTara Melcher
If it's any consolation, they still haven't fixed it. I just tried and I'm getting the same issue. I'm at the point where I'm ready to just give up on the challenge and go on to another module.
Will BissettWill Bissett
Still not fixed as at Apr 18.  To get around just go to the AppExchange directly and install from there.