function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Su Wang 3Su Wang 3 

Trailhead challenge error: Our trailbots are having a problem accessing your hands-on org. Please try again and if this issue persists refer to this article to fix the problem.

I have this error for all my 500 points challenges since two weeks ago.  I have searched other posts and checked that I am using the same account for my trailhead and my  I have tried to use different browsers, Chrome, IE and Firefox to have the same error.  It becomes very frustrated now.  I do have successful experience with the "Check challenge" of 500 points challenge before.
SandhyaSandhya (Salesforce Developers) 

Please refer below Salesforce help document for this error.
Hope this helps you!

If this helps you, please mark it as solved so that it will be available for others as a solution.

Thanks and Regards
Larry ThemlLarry Theml
I am also having this same issue with the DE, so I assume some change was made on the Trailhead side.  I never had this issue before and have 10+ badges. Regarding option 2 in the article, "Click the X in the action column of the DE you want to disconnect.",  I have no option to disconnect, so I can't proceed to the next step. My challenge is already coded in the DE,  so I'd prefer not to start over and create a TP. Is this issue being looked into ?   Thanks in advance.
Larry ThemlLarry Theml
I just resolved my issue. Not sure what changed on the Trailhead side,  but this is what I did.  I had only one DE (no Trailhead Playground) defined that I've been working on for months.  I ended up creating a TP and then setting the default to it. I then had the option to "X" or disconnect my DE.   I then attempted the challenge check (knowing it would fail).  I then set was able to reconnect my DE and make it my default - and my challenge was able to find my DE !   
Su Wang 3Su Wang 3
@Sandhya, I have followed the article you posted to no avail.
Su Wang 3Su Wang 3
@Larry Themi, I followed your advice to disable the TP.  But after that, I still encounter the same error.
Ver Alvin MakiramdamVer Alvin Makiramdam
Hi Team,

Any help is greatly appreciated.

Doug BittingDoug Bitting
The error you are receiving indicates that Trailhead was unable to retrieve an access token for your hands-on org.  The instructions in the linked article provide methods for resolving this issue.  Please make sure you are able to log in to your hands-on org separately from Trailhead and try to unlink and relink the org within Trailhead, as described in the linked article.  If that still isn't working for you, I invite you to log a case as instructed in the linked article.
Su Wang 3Su Wang 3
Hi, Doug, what linked article are you referring to?  Is it the one Sandhya posted?
Su Wang 3Su Wang 3
I solved this problem by disconnecting my and re-connect it.  But it is fuzzy in the article on how to do this in details.  If you only have, you can't disconnect it.  You will have to go to your trailhead "Launch your hands-on org" to create a trailhead playground first, then, you will see "x" next to your to disconnect.  Once you disconnect, I don't see any "Add New Button" as the article says.  Again, go back to "Launch your hands on org" dropdown and click on "Log into a Developer Edition".  This will add your back.  After this, click on "Check your challenge", the error should go away. Finally!!!
Soumy Jimmy 13Soumy Jimmy 13
Su Wang are a life saver..your tip really worked and this was not part of article...excellent....
Su Wang 3Su Wang 3
Soumy Jimmy 13, I was frustrated by it for a while so I am glad that what I have learned can help others.
@Wang .... thanks alot ... this is the right answer !!
Lina Eng 2Lina Eng 2
@Larry Theml...  Your solution worked for me!!  Thank you, thank you, thank you!!!...
Wasn't ready to redo all of my badges.
Rahul SharmaRahul Sharma
Not sure why but this really kind of solution sucks and does not give an descriptive error message.