function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Gloria Gutierrez 14Gloria Gutierrez 14 

Invalid field UserPreferencesHideS1BrowserUI on User Registration

I'm trying to setup a login / registration process in our sandboxes and am getting this error when signing up "Invalid field UserPreferencesHideS1BrowserUI" . Is this new and is there something in the documentation I am missing? 

In Management: Login and Registration
Community Builder Page: login
  • Allow Company username and password checked
  • Community Builder Page: Forgot Password
  • VF Page: Change Password
  • Allow external users to self-register: checked
  • Community Builder Page: Register
  • Profile (Self-Service User)
  • Account: (Generic account)
  • -- this avoids the Person accounts requirement.

User-added image
SandhyaSandhya (Salesforce Developers) 

I tried to research your question and got the below link in which it says UserPreferencesHideS1BrowserUI is not a valid field.See if that can help you in any way.

mapped fields like Saleforce1 user=UserPreferencesHideS1BrowserUI

Hope this helps you!

If this helps you, please mark it as solved.

Thanks and Regards

Kirra HughesKirra Hughes
I'm having this same issue. Was the cause ever determined?
Javier Peña LucenaJavier Peña Lucena

Hi all,
It is a matter of settings. This field is hidden in your org, because you have setting enableS1BrowserEnabled set as false.
I cannot not found this setting in the Org, so I fixed this situation deploying LightningExperience.settings file including this:

<?xml version="1.0" encoding="UTF-8"?>
<LightningExperienceSettings xmlns="">

Hope it helps,