+ Start a Discussion
LoganUTLoganUT 

Visualforce page shows a blank page after being deployed to production

Hello! 

I have built a Visualforce page and it has worked perfectly in a Developed enviornment and our Sandbox enviornment, but it was just deloyed to production and the tab set up for the VFP is completely blank.

Has anyone seen this issue before?

I have included the VFP code and a screen shot...
 
<apex:page standardController="Location_Master__c" recordSetVar="locMaster" sidebar="true" > 
        <apex:form >
        <apex:pageBlock title="Location Vendors" id="locationVendors">
        
            <!-- Vacancey List -->
       <apex:pageBlockTable value="{! locMaster }" var="locVac" >
                <apex:column >
                   <apex:facet name="header">URL</apex:facet>
                   <apex:outputLink value="/{!locVac.id}">{!locVac.Name}</apex:outputLink>
                </apex:column>
                <apex:column value="{! locVac.Current_Vendors__c}" />
                <apex:column value="{! locVac.Current_Value__c }" />
                <apex:column value="{! locVac.Available_Vendors__c }" />
                <apex:column value="{! locVac.Available_Value__c }" />

        </apex:pageBlockTable> 
             
<!-- Pagination -->
        <table style="widt: 100%"><tr>
            <td>
                Page: <apex:outputText value="{! PageNumber } of {! CEILING(ResultSize / PageSize) }"/>
            </td>
            <td align="center">
                <!-- Previous Page -->
                <!-- active -->
                <apex:commandLink action="{! Previous }" value=" Previous" rendered="{! HasPrevious }" />
                <!-- inactive (no earlier pages) -->
                <apex:outputText style="color: #ccc;" value=" Previous" rendered="{! NOT(HasPrevious) }" />
                
                &nbsp;&nbsp;
                
                <!-- Next Page -->
                <!-- active -->
                <apex:commandLink action="{! Next }" value="Next" rendered="{! HasNext }" />
                <!-- inactive (no more pages) -->
                <apex:outputText style="color: #ccc;" value="Next" rendered="{! NOT(HasNext) }" />
            </td>
            <td align="right">
                Records per page:
                <apex:selectList value="{! PageSize }" size="1">
                    <apex:selectOption itemValue="5" itemLabel="5" />
                    <apex:selectOption itemValue="20" itemLabel="20" />
                    <apex:selectOption itemValue="50" itemLabel="50" />
                    <apex:actionSupport event="onchange" reRender="locationVendors" />
                </apex:selectList>
            </td>
        </tr></table>            
            
        </apex:pageBlock>    
</apex:form>        
</apex:page>

User-added image
Best Answer chosen by LoganUT
LoganUTLoganUT
False alarm, assigned the wrong VFP to the tab....this has been a big project. I think my brain is tired...