+ Start a Discussion
Davide MolinariDavide Molinari 

related list custom object not showing Salesforce1

Hi all,
I created a custom object with a lookup relationship with Account. 
I added related list in the Account layout page, but it is not showing in Lightning Experience and in Salesforce1.
Am I missing something?

Thanks
Davide
Best Answer chosen by Davide Molinari
Lokesh KumarLokesh Kumar
HI Davide,

Can you please check the permissions means Field level security is visible for your profile or whoever trying to see and check Object permission too.. might be this can solve your problem. rest everything looks fine.

let me know if any luck .

Thanks !

All Answers

Rahul KumarRahul Kumar (Salesforce Developers) 
Hi Davide,
  • Related lists for objects that aren’t supported in Lightning Experience don’t appear anywhere in the interface, even if they’re included on an object’s page layout. Take a look here for more information Data Access and Views: Lightning Experience Limitations

  • Please check the below link for reference.
I hope it will be helpful.

Please mark it as best answer if it resolved the issue.

BestRegards
RahulKumar
Davide MolinariDavide Molinari
Hi Rahul,
in Winter 16 Release Note it is stated that related list for custom object are supported: 
https://releasenotes.docs.salesforce.com/en-us/winter16/release-notes/lex_gaps_limitations_data_access.htm

Something as changed?

Davide
Lokesh KumarLokesh Kumar
HI Davide,

if your custom object has look up relationship with lightning  non-supported  Objects then it will not visible in lightning or Salesforce 1.

Thanks !
Davide MolinariDavide Molinari
Hi Lokesh,
the relationship is with Account object, supported too.

Thanks,
Davide
manasa chudamanimanasa chudamani
Hi Davide,

Are you able to see related list in Salesforce Classic.Can You please check whether the Custom Object is having user permissions.

Thanks & Regards,
Manasa.G
 
Lokesh KumarLokesh Kumar
HI Davide,

Can you please check the permissions means Field level security is visible for your profile or whoever trying to see and check Object permission too.. might be this can solve your problem. rest everything looks fine.

let me know if any luck .

Thanks !
This was selected as the best answer
Davide MolinariDavide Molinari
I'm able to see it in classic.
It was a matter of field permission, even if there were missing only permission on custom field, not on "Name", "CreatedBy" and so on...

Thanks all,
Davide
Lokesh KumarLokesh Kumar
Yes, Please test in classic first !!
Davide MolinariDavide Molinari
Already tested and it was showing!