function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Unable to install the Salesforce VR Toolkit on Unity

Greetings, I am working on the Salesforce Build a 3D Virtual Reality App project in trailhead and have downloaded Unity and Google's VR tools, but when I attempt to install the VR toolkit, I encounter this error?

Assets/Salesforce/Components/Scripts/Trigger.cs(24,51): error CS0246: The type or namespace name `GazeInputModule' could not be found. Are you missing an assembly reference?

Anything that I am missing.
Best Answer chosen by MedhanieHabte
Huzzah! It worked! I owe you one.

All Answers

Rob Cowell 14Rob Cowell 14
Google deprecated the GazeInputModule in the April release of their API - if you look at the console output in Unity it'll tell you what to replace it with.  I believe it's now GvrPointerInputModule, but please check your logs rather than rely on my recollection.  There's a few places this happens, and a couple of other deprecated modules but you should be able to replace them easily enough based on the error messages it gives in Unity.

Double-clicking on the error message will take you to the relevant module/line of code that needs changing in the MonoDevelop-Unity editor.  Change the reference and save the file, the project should update and eventually you'll see SalesforceVR in your Unity menus.
Huzzah! It worked! I owe you one.
This was selected as the best answer
Rob Cowell 14Rob Cowell 14
Glad to help - if you could mark my answer as the Best Answer, I'd be glad to receive my first ever points on this forum ;-)
I wish I could from email! But alas I did.
I am trying to build the same app, but while installing Salesforce toolkit, I encountered this error: "The name 'itween' does not exist in the current context" could you help me out with this. 
Thank you.