+ Start a Discussion
Everita MackoEverita Macko 

Data integrations Superbadge challenge 9, INTERNAL SERVER ERROR

I am getting Internal server error on Data Integratons Superbadge challenge 9. 
User-added image
 
Best Answer chosen by Everita Macko
Bunty AgrawalBunty Agrawal
I can report back that it is working as expected now.

All Answers

NagendraNagendra (Salesforce Developers) 
Hi Everita,

Firstly you didn't specify when exactly you are getting this error.
 
  • There is no indexing locally on Salesforce for external objects. External objects are all stored on an external system and thus rely on search capabilities of that external system. 
  • If a search is enabled for the data source, Salesforce simply does a call out to the endpoint for each external object backed by that data source and displays the results returned by the data source. The checkbox mentioned in step 1 above controls whether Salesforce will make the call out to find search results.
  • Click "Enable Search" in an External Data Source to enables SOSL and Salesforce global searches for the external data. To control which external objects are searchable, select or deselect “Allow Search” on each external object.
  • There are efforts in motion where we are working on making it even more clear that certain problems may be caused on the external system side in an upcoming release (safe harbor). Until then, a general working rule is if the error message contains "Attempted to reach an URL", something about the endpoint or URL, or some sort of HTTP error code, it can be assumed that this is a problem with the external system.
  • More to the point if you see an "Error received: 500" that is an HTTP code error coming from the external system.  With OData it usually has to do with the external system not following OData specification, a problem with a gateway redirecting and causing issues with the request, or especially with search, it not being configured since it is not standard.
  • The workaround here is to disable search on the Data source under Setup | Build | Develop | External Data Sources.
  • Note that Salesforce cannot disable indexing on external objects based on the above at this time.
Thanks,
Nagendra.
Vitaly MininVitaly Minin
I have the same problem, it seems to me that trouble is with external system(endpoint "https://sb-integration-is.herokuapp.com/odata/"), because when I try to access invoice records by typing "https://sb-integration-is.herokuapp.com/odata/invoices?" through my browser I get HTTP Error 500( Internal Server Error ).
Everita MackoEverita Macko
Nagendra, 
This error apears on the Data Integrations Superbadge, Challenge 9.
I tried to check and uncheck those checkboxes, but I still have this error. 
User-added imageUser-added image
Bunty AgrawalBunty Agrawal
Yep, definitely an issue with the endpoint, I added a tab just to explore the data and the same error
User-added image

Please Fix it, team Trailhead!
Bunty AgrawalBunty Agrawal
I can report back that it is working as expected now.
This was selected as the best answer