function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Manu Mahajan 22Manu Mahajan 22 

Not able to pass Challenge for- Create a Lens Using a Polar Gauge Chart with Chart Icons

According to the requirement of Project  I have created Lense named worldwide_sales_with_flags. But still I am getting the error:User-added imageUser-added image
Deepak Techmodel5Deepak Techmodel5
Hi Manu,

                Whether your gauge chart is enabled, If it is enabled Kindly share with me the flow! I will help you asap
Manu Mahajan 22Manu Mahajan 22
Hi polar gauge is enabled.
User-added image
Manu Mahajan 22Manu Mahajan 22
The flow is same as project flow. Are you able to pass the challenge
Manu Mahajan 22Manu Mahajan 22
I found the issue-Lenses to be named worldwide sales with flags. Salesforce needs to change the title name
MarioEmanuele LagadariMarioEmanuele Lagadari
Another way is delete the last lens created with this name and restart the process. 
In my case works works
Duncan Holmes 14Duncan Holmes 14
I'm still having this issue, the error message i get is: Polar Gauge Chart doesn't exist. Please check the instructions.

I've fiddled with the title of the lens and deleted and recreated the lens multiple times but the issue persists, can anybody help with this?
Nikhil Jaitly 8Nikhil Jaitly 8
I am also struggling to get through this for past couple of days. Also, the screenshots in the module have changed after the release, I am assuming modules too have changed a bit after the release.

I have also seen this not working for one of my other colleagues, who did the badge before the release upgrade and now couldn't do it (in a new dev org).

Adrienne Boice 15Adrienne Boice 15
I am getting the error message: "Polar Gauge Chart doesn't exist. Please check the instructions." Very frustrating. It exists! 
Cecilia Blanco 2Cecilia Blanco 2
I'm getting the same "Polar Gauge Chart doesn't exist." message as well. I skipped to the next module and was able to complete that, so the gauges are definitely there!
Jess BurghJess Burgh
Hey all. I'm getting the same error message "Polar Gauge Chart doesn't exist." What am I doing wrong? 
kerry Reitnauerkerry Reitnauer
Having same problem and tried the renaming suggestion above also...  "Polar Gauge Chart doesn't exist."
Jess BurghJess Burgh
I tried renaming it too. And still get the same message, in a different org. I passed all the other modules, but this one is keeping me from getting the badge. :(
Bhupendra chauhan 6Bhupendra chauhan 6
I am also facing same issue...
Had the same issue and it was so frustrating not passing this module
Vijaya SridharanVijaya Sridharan
Same issue. Polar Gauge chart with names 'worldwide sales with flags' and 'worldwide_sales_with_flags' exist in Private app. Trailhead still says 'Polar Gauge Chart doesn't exist. Please check the instructions'.
Bangjie HuangBangjie Huang
Same issue. Anyone to take care of it?
Elizabeth WhelanElizabeth Whelan
I'm having the same challenge too. I've remade the lens 4 times, and still cannot complete the challenge. Hopefully someone from Salesforce will see this and fix the issue soon!
Bo ThaiBo Thai

I hope the Salesforce Moderator is able to help us resolve this issue with this Trailhead modules challenge. I think everyone is stuck on this and can't pass it.

please help us all.

Thank you 
Matt FulpMatt Fulp
Yes, I'm also stuck on this module. I created the chart yesterday and got the same error that it doesn't exist, then deleted everything this morning and started from scratch, and still get the error.
Bo ThaiBo Thai
Hey, I was told it was a known bug and they are working on it. Bo
Will Conrad 9Will Conrad 9
Has this badge ever been accomplished?
Bo ThaiBo Thai
Hi Will, No, I have never competed this badge before Bo
Chris DuarteChris Duarte
Hi all - there is an issue with this project originating with the Summer '18 release. The issue was unfortunately not uncovered in testing, but it is being resolved now. Please hold off on this project until after the fix goes live -- ETA is about 2 weeks from now. Our apologies for the issue.
pretty lens is waiting to complete!
User-added image
ok waiting.......
Jess BurghJess Burgh
Will hold off until the issue is resolved. 
Francisco Salanga IIIFrancisco Salanga III
Hey folks. This project has been fixed and validated. Time to get that badge! Don't hesitate to reach out if there are any questions, comments, or concerns.
Confirm fixed, got the badge, thanks! 
Matt FulpMatt Fulp
That worked, thanks!
Greate it worked!
I'm still hitting issues with this one.
I've deleted and rebuilt the lens but get an error relating to the bins being incorrect.
I've copied the values directly from the task and made sure the bin colours are all unique but I still get the error:
"Step not yet complete... here's what's wrong:
Looks like you entered the wrong bin values. Please ensure that the 3 bin values have been entered correctly.​"

User-added image

Anyone else getting this problem?

I've just tried it in a new dev org and get the same issue.
I also don't see the flags appear after selecting the 'use icons' option either. Both these problems have occurred on both dev orgs.
Francisco Salanga IIIFrancisco Salanga III
@LiamB so sorry you're still getting issues with this one. Please log a ticket so we can track that and fix ASAP.
Zeina Saad 15Zeina Saad 15
I'm still getting the error that everyone reported.  I have a lens called 'worldwide_sales_with_flags', but I keep getting the error :

Step not yet complete... here's what's wrong:
A lense called 'worldwide_sales_with_flags' doesn't exist. Please check the instructions.

I'm completed the rest of the project. Anyone else still having trouble? I created the dev org today and worked through the rest of the project today, no problem.

Ian MedernachIan Medernach
Getting the error as well - created multiple dashboards; one with the underscore and one without and no luck.
Yogini MaheshwariYogini Maheshwari
Getting this error - A lense called 'worldwide_sales_with_flags' doesn't exist. Please check the instructions.
Everything is done as per the instructions and saved the lens as 'worldwide_sales_with_flags' only. Still not able to complete the unit.
Ash Aragam 7Ash Aragam 7
I get the following error - Step not yet complete... here's what's wrong:
Dashboard 'Worldwide_Sales' doesn't exist. Please check the instructions..

Tried to change the dashboard name to what is in the error message, but unable to complete the challenge. Anyone else encountered this issue?
祐 秋山祐 秋山
I'm facing exactly same issue.
it says"A lense called 'worldwide_sales_with_flags' doesn't exist. Please check the instructions."
i deleted lense once, and made the lense again along the instruction written.
Mohamed FERICHMohamed FERICH
Hello everyone,
Please name the dashboard "worldwide sales with flags" and enter the bins values manually no Copy-Paste.
Lokesh Rekapalli 12Lokesh Rekapalli 12
I am facing this error. couldn't find a way out. tried recreating this lens couple of times.
PX AdminPX Admin
I'm getting the same issue even after saving the same lense with two different names:
. worldwide_sales_with_flags
. worldwide sales with flags

I certainly checked multiple times all the steps .. everything looks good ... still I get the below error:

Step not yet complete in
A lense called 'worldwide_sales_with_flags' doesn't exist. Please check the instructions.

:(   :(   :(
PX AdminPX Admin
I just cloned it and renamed .. it worked this time  :)
nitesh agarwal 42nitesh agarwal 42

make sure you the match the color also accoring to trailhead and also click on the  up arrow once your done with setting color and it worked for me!!User-added image
Marcus YeoMarcus Yeo
Clear your cache, then clone it and rename to "Worldwide Sales with Flags". Worked for me.
Sharad Chandra Maheshwari 1Sharad Chandra Maheshwari 1
As noted by Marcus Yeo- cloning the lens and saving it as  "Worldwide Sales with Flags" worked for me
Madlen Kopp 7Madlen Kopp 7
Anyone else experiencing the issue that the whole "Use icons" checkbox is missing?
In the polar gauge settings I only see:
Center Size (80%)
Show value as (Compact Number)
and then the "Range values" section starts...
Anestis ZioulisAnestis Zioulis

I didn't have to rename the lens. In my case the problem was the query. This fixed it for me:

q = load "worldwide_sales_with_flags";
q = group q by 'Country';
q = foreach q generate 'Country' as 'Country', sum('Value') as 'sum_value', first('Flag_img_url') as 'Flag_img_url';
q = order q by 'Country' asc;
q = limit q 2000;

Note: I had Flag_img_url with a capital F in the csv. You can change it to lowercase if your csv is different.
Also the url in the csv was something like this for me (as of 6th Sept 2023):

https:// <username>-dev-ed-develop.lightning.force com/file-asset/<filename>

If the path is not correct you won't be able to see the flags.