function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Benjamin GittinsBenjamin Gittins 


This SERIOUS bug is verified to occur on my deployment ONLY in Witner '18 sandbox, and NOT in my Summer '17 production environment.  The FLOW hangs, without reporting ANY error messages (even when the debug log is set with FINE grain reporting) when: 

1) Using an assignment element:  The value of a picklist field of a custom object is assigned a PICKLIST VALUE.  The value being assigned is spelt correctly.

2) Any time after that assignment, a SCREEN element is opened in the flow.  At this point, the flow HANGS without displaying any of the content of that SCREEN element.  No errors are generated.  No debug log entry is generated (presumably because the flow Never Ends!)

It does not matter what PICKLIST value is used. It does not matter if picklist field is "Required" or not.  It does not matter if "Restrict picklist to the values defined in the value set" is set or not. 

When i use change sets and move the flow from Winter '18 across to Summer '17, the flow works CORRECTLY on Summer '17.

If this fault is occuring in all Winter'18 deployments, it will affect a very large number of users.  

I attempt to file a critical bug report in the online support request for Salesforce system, but was unable to. So i am reporting this critical bug here.

Benjamin GittinsBenjamin Gittins

I have now tried modulating the number of PICKLIST values, and the value of each PICKLIST without any success. I have also now tried creating a new PICKLIST field, with just one PICKLIST value, and the fault occurs when i just assign a value to that new PICKLIST field.  

However, I have obvserved that i have a custom object with 21 fields that has a PICKLIST field that does not crash when it is assigned a value...  The custom object that is failing for me has 77 fields and some of those are long_text fields... I am wondering if this problem only occurs on custom objects with a large number of fields, or custom objects with large files in it... 



Dianne Yazbeck 8Dianne Yazbeck 8

I am having this issue now and wonder if there has been a fix to this?  My flow is calling for an update on a custom object's picklist and does not work - no error - it just hangs up and does not update the field.

Any input would be appreciated.

Kaushik AdvancedApexKaushik AdvancedApex
Any suggestion on how to resolve this?
ShirishaShirisha (Salesforce Developers) 
Hi Kaushik and Dianne,


Please feel free to raise a case with the support team if you have working and non working scenarios with you to confirm,if this is bug or any other implementation issue.

Kindly mark it as best answer if it helps so that it can help others in the future.

Warm Regards,
Shirisha Pathuri