function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Kajal KantariaKajal Kantaria 

An internal server error has occurred Error ID: 84564146-14190 (747219706)

I have been dealing with this issue for 2 days. When I click on Account Tab and select one of the account from list view, it gives me this error. I called technical support but they don't provide standard support to developer account. Please help me to solve this problem.

An internal server error has occurred
An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience. 

Thank you again for your patience and assistance. And thanks for using! 

Error ID: 84564146-14190 (747219706)
NagendraNagendra (Salesforce Developers) 
Hi Kajal,

Sorry for this issue you are encountering.

This type of error indicates that an error has occurred that hasn't been trapped by the platform - a low-level java exception for example.
If you need to move quicker than, start removing functionality from the component to isolate where the problem occurs and see if there are any other mechanisms you can use.

If the problem continues may I suggest you please clear all the cookies and cache and log out of all accounts and log in once again which should resolve the issue.

Still, if the problem persists give a try by attempting the same in a different browser which should do the trick.

Hope this helps.

Please mark this as solved if it's resolved so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Kajal KantariaKajal Kantaria
I tried to attemp the same in a different browser but no luck. Thank you Nagendra for the reply. Technical support told me to get help from the Developer Forum or creat another developer account as it's free. I'll keep you posted if I solve the problem.

Ruta GalanskaRuta Galanska

I know that year later, but had the same problem and couldnt figure out why, so just gonna put it here so maybe to other thrailheaders it will be useful.

In my case the error appeared because i had some errors in code. Tried to narrow comoponents (not the main one, but seperate the small ones who is depended each on ther) which should be shown in App (app container). Basicly that's how i would in which component is an error and deep dive in all of  , : ; ' " < />, if values have the right and necessary field, style, limits... . Basicly the reason was very tiny

It might be or not to be your case...but something to consider for sure.

Ajay K DubediAjay K Dubedi
Hi Kajal,
I was facing this problem. For this, you need to update your aura attribute. Especially this error occurs because of using the bad syntax of sObject.
Like This:   <aura:attribute name="leadObj" type="Lead" default="{'sObjectType':'Lead'}"/>
I hope you find the above solution helpful. If it does, please mark as Best Answer to help others too.
Ajay Dubedi
Aishwarya TKM 14Aishwarya TKM 14
Hi, Are you using Classic or Lightning version ? This error might occur when trying to access Lightning component without lightning permission from Classic view.

Aishwarya TKM