function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Lindsay Schinasi 5Lindsay Schinasi 5 

Invalid 'X-Frame-Options' header encountered when loading

got this when following trailhead use standard controller instructions (working through section: find a record ID

any help fixing this?

Invalid 'X-Frame-Options' header encountered when loading '': 'ALLOW-FROM' is not a recognized directive. The header will be ignored.
Nguyen NghiaNguyen Nghia
I have got this issue too.
Kyle CunninghamKyle Cunningham
What browser are you using?
I was encountering this message in the dev console while I was writing some visualforce. It looks like this option is set by default for visualforce pages to help prevent clickjacking and Chrome doesn't support the ALLOW-FROM X-frame option ( If this is preventing you from completing a trailhead then you could try using Firefox or IE. Or you could try adding the showHeader="false" arg to your page tag. This disables the default headers in visualforce but you may still fail the trailhead validation test depending on how the validation is calculated. 
Rick MooneyRick Mooney
I had the same issue using chrome.  Switched to firefox and the page worked as expected.
Srivani GorthiSrivani Gorthi
I faced exception in chrome and firefox, Can someone suggest possible solution for this
Nikolajs MitjulsNikolajs Mitjuls
I have the same problem and the only way I found that you must open your sandbox Account you work with, open JS console, add that part of code with YOUR URL name 
    {"url": "/apex/pageName"}).fire();
and then refresh that new tab all the times you doing any changes in you code.
Hopefully I helped to someone :)
Ankita Bhatt 1994Ankita Bhatt 1994
I faced exception in chrome and firefox, Can any one suggest any solution.