+ Start a Discussion
Serena SchultzSerena Schultz 

Einstein Vision Component Error


I'm trying to create the Einstein Vision Lightning App per this trailhead (https://trailhead.salesforce.com/projects/build-a-cat-rescue-app-that-recognizes-cat-breeds/steps/cat-recognition-app-ui-einstein-vision). I added the Apex Class and Lightning Component as shown, but when I add the component or try to use it I get this error:
User-added image

Any idea what this is or how to fix?

Make sure you provided the controller name in the component and XML and "getDatasets" function has the same name in Apex Class and has @Aura Enabled ...More can be provided if you can paste your code here. 
Serena SchultzSerena Schultz
Thanks @amidstcloud. I'm literally copy/pasting the code for my Apex Class and Component from this Trailhead (https://trailhead.salesforce.com/projects/build-a-cat-rescue-app-that-recognizes-cat-breeds/steps/cat-recognition-app-ui-einstein-vision) so I'm very confused about why it wouldn't work. The class has @Aura Enabled. Other thoughts?
Joe EdwardsJoe Edwards
Doing the same thing, getting the same result. I'm willing to bet Serena has given up by now, seeing as how there has been no reply in almost 5 months.
Md SadikMd Sadik
User-added image
im gettting this error while clicking on einstein viosn tab
Hi Md Sadik,

I am also getting the same error, Did you able to resolve this?

Thank You.