function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Suban khoja 3Suban khoja 3 

Error: Faraday::ClientError. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio​ns must specify no more than one row for retrieval. Result size: 2

How to solve This Error...
Andy BraveryAndy Bravery
Yes, I am getting this one too, on the Challenge in the unit Share Values with Global Value Sets in the Picklist Administration trail.
Julie Mullins 13Julie Mullins 13
I am getting this error on the Share Values with Global Value Sets in the Picklist Administration badge as well
Corrina CohenCorrina Cohen
I am gettting the same error on the Share Values with Global Value Sets in the Picklist Administration challenge 
Wilmer DueñoWilmer Dueño
I too am receiving the same exact error message in the same Global Value Sets Picklist Administration challenge. I noticed that this Picklist Administration badge has been recently added as I had completed the Admin Intermediate Trailhead some time ago and saw that my completion percentage no longer was 100% with the new addition. 
Corrina CohenCorrina Cohen
I created a new/clean hands on ord and redid this. For some reason it was successful on a clean install. 
Wilmer DueñoWilmer Dueño
I can verify that creating a new Hands-On Org and setting up the picklist in challenge 1 of this badge then completing the Global Value Sets challenge will work and not yield an error.
Eric JJ van HorssenEric JJ van Horssen
Just checked with a colleague with the same issue, he also followed the steps in the text, and has two global value sets, it seems this was not accounted for, make sure you only have the one global value set.
Andy BraveryAndy Bravery
No - I thought of that and checked it out. There were no other global value sets.
Like others above I retried the challenge with a fresh sandbox and it worked ok.
Eric JJ van HorssenEric JJ van Horssen
No worries, it worked here:

I suppose, Trailhead should look into this anyway, why they get this error.
Walter Gold 5Walter Gold 5
This error is now also showing up for the Challenge:
Customize a Sales Path for Your Team: Customize Opportunity Stages

"There was an unhandled exception. Please reference ID: OIEEXEDH. Error: Faraday::ClientError. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio​ns must specify no more than one row for retrieval. Result size: 2"

However this challenge, nor the previous steps, does not ask the user to make any picklist setting choices. There is no way to go and modify this relative to the challenge.
Eric JJ van HorssenEric JJ van Horssen
@Walter Gold 5

I have finished those units, and am unable to see what the challenge was.

Mind you, the error message suggests to me, that the search is for some kind of metadata, and that more than one of that type is returned, there is no indication whether this is about picklists, or as it seems to be in the other module, about having more than one global value set.

The unit you point to, is about setting up a Path, mind you, normally this would be the first, can it be you have two Paths, instead of one?
Chris DuarteChris Duarte
Hi everyone -- the code for this challenge is looking for 1 picklist value only. If you have more than 1 set up, the challenge will fail. We are currently working on changing the code to accept more than 1 value, but in the immediate term, if you either delete any extra values or do the challenge in a new Trailhead Playground, you should be able to get past this error. My apologies for the issue.
Eric JJ van HorssenEric JJ van Horssen
TXS @Chris as always you ar on top of it
Terry Ulanch 17Terry Ulanch 17
I am getting this error in the 

Quick Start: Lightning Components
Create a Lightning Component

here is the text of the error

There was an unhandled exception. Please reference ID: QQMKOXIR. Error: Faraday::ClientError. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio​ns must specify no more than one row for retrieval. Result size: 2

I am not aware of any picklist being invovled in this challenge...
Christina Wildau 5Christina Wildau 5
I got the same error and it was because I created the Ingredients global value picklist in the module as I was following along. It wouldn't let me delete it even though I deleted the custom picklist fields that were using it. Well, I should say it was giving me an error when I tried to delete it but then it had an undelete option when I clicked on the Ingredients global value picklist after trying to delete it. Not sure what that was all about but the challenge passed in a new playground.
Yves Asselin 3Yves Asselin 3
This is another example of pourly written lessons. Usually, when we follow a lesson, we always try it out as we go. Many lessons now only check if you followed corretly. However, in this lesson, this causes an error.... so if you followed the lesson as you should... you must CREATE A NEW ORG, and restart from the beginning but instead of following the instructions, only do the challenges... then it works fine...
Chris DuarteChris Duarte
No, this is a case where the challenge was coded to look for 1 value only. It was a mistake and was not caught in testing, but we corrected it last weekend to accept more than 1 value. 

The information I provided in this thread was a workaround to help learners pass the challenge, and also to help them understand why the challenge was failing, in the spirit of transparency. 
Yves Asselin 3Yves Asselin 3
Chris, I am not sure what you are saying NO to... As of this morning, i started this new section in a brand new org. I followed the lessons, then did the challenges. When I got to the third part I got the error.  Once I read up on it on the forum, i recreated a new ORG... redid the first two steps.. and 15 waisted minutes later, i did exacly what I did previously and it worked. Just like it is mention in the forum answers... 

Maybe the error was not correctly or the changes were not applied... But if you dont believe me, try for yourself... just remember to follow the lessons and enter data as they ask before you do the challenge...
Chris DuarteChris Duarte
I'm saying this was an error in the challenge checker, that it only was checking for one value -- not a case of a writer doing a poor job explaining a concept. I wanted to make sure you understood that it was something we were fixing in the challenge check itself.

The fix for that issue was in this past weekend's release. I'll check with our team to make sure the fix went out! Thanks.
Yves Asselin 3Yves Asselin 3
Here is the thing... when I say poor writing it is because once a lesson is written, it should be verified and steps should be followed to see if it works. In this case, for some reason the writer forgets or omits to tell us NOT to follow and do the steps in our dev environment like we have done in almost every other lesson... The other answer would be my favorite, and that is what I have seen in the new modules where you follow the leson in your playground and then check the challenge... This is really the way to go... But either way. The WRITER needs to modify this lesson to either tell the user not to follow in the org as he is following the lesson OR have us enter the required challenge data as we follow the lesson.... 
Eric JJ van HorssenEric JJ van Horssen
Indeed a bit confusing, for Modules, in general you do not follow the text, you only need to do what is in the Challenge, but for Projects, you follow the text and the Challenge is to check whether you did.
See here:

Apart from really looking at whether you opened a Module or a Project, it is not always clear from the start of the texts, which of the two types it concerns.

In the early days, a trail consisted of Modules, with at the end, related Projects, nowadays, a Trail, might contain a Project. If you are not aware of the different approaches for Modules and Projects, this can be really confusing.

Trail with related Projects, as in the old days
Trail with related Projects, and a Project as part of the trail:

On the other hand, whether you follow the text and perform the actions or not, the Challenge should check the Challenge only, without having a conflict with whether you do what is in the text or not. As far as I understand from @Chris Duarte, the code should have been updated so as to not have a conflict anymore, in case you followed both the text and the Challenge.

@Yves Asselin 3, mind you, maybe I just have not noticed, but if there are indeed Modules, in which you have to work like in a Project, then you are totally correct, and Trailhead should make sure to align this better.
Chris DuarteChris Duarte
@Yves I agree with you -- what I'm trying to tell you is, this isn't the writer's fault -- the writer doesn't code the challenges. And this is simply a case of the challenge being too restrictive in what it was checking for. 

I agree with you also on testing. We have several people (in addition to the writer) test the modules -- they just didn't catch that the challenge checker would fail if you'd done (1) the example in the unit and (2) the hands-on challenge. 

We try very hard to be perfect; but we do sometimes make mistakes. I'll be the first to say that, and it's my responsibility to address them. I'll run through this unit right now and I'll make sure the fix was applied.
Chris DuarteChris Duarte
@Eric modules are distinct from projects. As you mentioned, with projects, we give you step-by-step instructions to follow. With modules, we teach you skills, then give you a hands-on challenge to try.

However, we should *not* give you a hands-on challenge that won't work if you followed along with examples in the unit. That's what folks have been experiencing with this picklists unit. It was a mistake and it's my responsibility. I'll run through it now and see if the fix somehow didn't get applied last weekend. It should have been part of that release.
Chris DuarteChris Duarte
Okay! I have an update for you @Eric and @Yves.

Two things:

1. I agree that the way we're weaving examples in the unit with the challenges at the bottom needs reworking. I just went through the module personally and I think it's confusing as is. I will log a bug for that work to get completed for our next content release (unfortunately with Dreamforce and the holidays here in the states, it will take us a bit longer than I'd like, but I'll make sure it gets handled).

2. The third challenge did *not* have the fix applied. I will investigate how we missed that. I figured we just need to delete the second global picklist value -- but I couldn't get it to delete. I spent about 30 minutes poking around on this one and then discovered it's a known issue.

I suppose the only good news here is that recreating this in a different playground takes about 5 minutes. I just launched one of my other playgrounds, made the Macaron Flavor field on the Product object, added the values, promoted them to global, and then made the Shirt field, and passed. That's the workaround until I can get the fix applied.

My apologies again for the issue, and thank you all for the feedback.
Yves Asselin 3Yves Asselin 3
Thanks Chris The only thing i dont understand is why instead of re-coding your validator, you dont simply do like the first two parts of that section and change a few words in the lesson... instead of saying enter a name, have us enter the real information and then have the challenge check the steps... -Y
Chris DuarteChris Duarte
That might be what we end up doing @Yves! In this case, I need to work with both the writer to clarify the content and the challenge developer to update the challenge. Reason being, someone may in fact have more than 1 global picklist value in an org, and we shouldn't be restrictive and look for only one value. 

It would be like this: Let's say we had you make a custom field as part of a challenge, and we made the challenge check fail if you had more than 1 custom field in your org. See how odd it is to do that? The challenge shouldn't fail simply because you have more than 1 value.

Again, my apologies and thank you for the feedback. I'll post once we have a resolution. Until then, note the workaround above.
Sándor SzigetiSándor Szigeti
I managed to solve this without the creation of a new org. 
The problem disappeared after the complete erasure of the Ingredients global value set: delete then ERASE from Deleted Global Value Sets.
First you have to unassign it, if it is already used somewhere.
@Sándor Szigeti - this worked..thanks!
Sándor SzigetiSándor Szigeti
you are welcome! ☺
Dibya PanigrahiDibya Panigrahi
For the purpose of trailhead completion, the problem is a solved one now. I followed the suggestion by Sándor Szigeti. Thank you Sándor.

I am not sure if I would face the same problem in the industry where there could be more than one global picklists. 
Sitanshu TripathiSitanshu Tripathi
I think there is no solution on same org.
1. Just create a new org.
2. Add your trailhead with the new org and then try
I'm 100 % sure it's working
3. Click on Connect to Org and login with new org.
User-added image

User-added image
Still same error !!

There was an unhandled exception. Please reference ID: HGWGQSLP. Error: Faraday::ClientError. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio​ns must specify no more than one row for retrieval. Result size: 2
Velu Palani 32Velu Palani 32

There was an unhandled exception. Please reference ID: MHPGQPPW. Error: Faraday::ClientError. Message: MALFORMED_QUERY: When retrieving results with Metadata or FullName fields, the query qualificatio ns must specify no more than one row for retrieval. Result size: 2

I am getting this error in Lightning Experience Rollout Specialist... What is the next step?
Sándor SzigetiSándor Szigeti
Did you try the solution recommended by me on 22 November 2017?
You don't have to create a new org...
David So 3David So 3
Re: Question by Terry Ulanch 17, has anyone tried to address his issue?  I'm getting the same while going through Quick Start: Lightning Components, Create a Lightning Component in TrailHead
David So 3David So 3
Never Mind, creating a new trailhead playground org did the trick.  Thanks!
Serhii KushnirenkoSerhii Kushnirenko
In module:
Quick Start: Lightning Components
Create a Lightning Component

It helped me to avoid this error after,
I changed Label of the page.
User-added image
Philip SinghPhilip Singh
Serhii Kushnirenko! You are the man! you posted your answer 2 days ago but i just passed the module.. thank the lord!
Divesh JaitleyDivesh Jaitley

As per my experience with Trailhead Assignments - the Error "MALFORMED_QUERY" is thrown when TEST Query (used for checking assignment results) returns NULL. 
In other words, The Test is expecting some object or value to be present in your org but found it missing. 
Divesh JaitleyDivesh Jaitley
Please checks the required object/values exists and is spelled correctly. 
Chad GerthChad Gerth
Got this error in both a Developer and a new, clean Trailhead Playground. None of these workarounds seem to work for me.
Hello Everybody, i'm encoutring the same problem with step 8 , can anyone help me resolving that issue please. i don't what the your global picklist, that you are talking about

User-added image

here the screenshot of my dashboard if it can help you
User-added image
Jacob KleimanJacob Kleiman

Elie I came across the same problem just now when trying to add the dashboard to the SolarBot App Page. I don't even see the page layout after I created it either.

 Faraday Error

SolarBot App Page Dashboard

Jacob KleimanJacob Kleiman
I figured out the solution! You have to go to your Lightning App Builder and delete any new copies that you had accidentally made. I had two extra SolarBot App pages in here and deleted the custom tabs with them and the pages and the error went away.

User-added image
I am getting the same error while trying to complete the 'Discover Lightning Actions' section of Lightning Alternatives to Javascript buttons.
@Chris Duarte - Any suggestions on how to remove the error?

Martha VMartha V
Thanks for this solution! I could have spent days trying to figure this out on my own :)   I had the same problem with the duplicate lightning page in the Process Automation Specialist super badge.
Raman Bajetha 8Raman Bajetha 8
I have spent days trying to figure this out on my own, finally i am with one solution, this error occured when we already had a same object name which you must have deleted before installing the desired app and then haven't deleted it premanently from salesforce classic this must be the reason error occured.
Dinesh 1627Dinesh 1627
I got this error while doing the below trailhead badge - Proces builder

I made a mistake and the error came 
then i fixed the error and i cloned the same process builder and checked the challenge
same error came
i deleted the cloned process builder - version 1 and checked the challenge
challenge completed successfully
Chetan Awate 9Chetan Awate 9

Hi Suban,

Here the issue is we cannot query FullName field if we do have multiple fexipages on same object 
Query FullName field only if the query result contains no more than one record. Otherwise, an error is returned. If more than one record exists, use multiple queries to retrieve the records.
You can query instead NamespacePrefix + DeveloperName and use wherever you want FullName  (FullName = NamespacePrefix + DeveloperName).
I hope this will helpfull