function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Ryan Shaw SDRyan Shaw SD 

Trailhead Challenge Error: Salesforce1 Security and Compliance

In the Salesforce1 Security and Compliance module, I am getting an error that I think is related to the name change of Salesforce1. 

Challenge Not yet complete... here's what's wrong: 
Could not find the 'Salesforce1 for Android' Connected App with the specified settings.

The Cennected App that is created is now called:  
Salesforce for Android

I double-checked my Connected App settings and believe they are correct, so I'd like to know if Trailhead is incorrectly looking for the wrong Connected App name. 

I encounter the same problem... so can not complete these module
I think that this is due to the fact that apps name has changed in "Android" and "IOs"
Ryan Shaw SDRyan Shaw SD
I tried to install the Managed Package instead of letting it auto-install when I connected Salesforce1. Although it installed a connected app with the right name, "Salesforce1 for Android", it still doesn't recognize it when I verify, and I get the same error. -Ryan
Phil BlaneyPhil Blaney
Same for me, very frustrating!
Frank van der VoortFrank van der Voort

Same here. Anyone solved this challenge already?

"Challenge Not yet complete... here's what's wrong: 
Could not find the 'Salesforce1 for Android' Connected App with the specified settings."

Anja BotićAnja Botić

Did anyone solve this problem? I am having the same problem. Looking at the another discussion about it:

People the are also guessing it's because the name has changed. Both discussions are posted within the past 7days.

Brandon LibmanBrandon Libman
I'm stuck on verifying blocked users in this module. Blocking me from completing the whole trail. No matter what I do, I can't seem to get it to verify that salesforce for ios is indeed blocked xD
Anja BotićAnja Botić
That means you've finished this one. How (and when)? What's the name of the app when you open it to change settings: Salesforce for Android/iOS, or Salesforce1 for Android/iOS?
Brandon LibmanBrandon Libman
Hi Anja,

It's called "Salesforce for iOS", not "Salesforce1" :/
Anja BotićAnja Botić
Maybe that's what's preventing you from passing the challenge too. 
Chris DuarteChris Duarte
Issue now resolved. Our apologies for the trouble.
Brandon LibmanBrandon Libman
Thank you Chris, I have now completed this trail :)
I'm getting this error again, did something change?
Shasidhar KothaShasidhar Kotha
I am also facing same issue though I edited with correct values as given in the challenge.

Mobile Integration
Lock App After10 minutes  
PIN Length5