function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Tom ButtTom Butt 

Cannot pass Monitor and Manage Salesforce1 Usage

The challenge requires me to block all users' access to the Salesforce1 for iOS app or the Salesforce1 for Android app. Under my connected apps i can only see "Salesforce for iOS" and this was the one I blocked. I have verified that my Salesforce1 app session has been revoked.

When I submit my challenge it gives the following error:

"It doesn't appear that you've blocked all users' access to either the Salesforce1 for iOS or Salesforce1 for Android app. Please check again."

How can I get around this error? Would the fact that my connected app is simply called "Salesforce for iOS" (missing the "1") have anything to do with it?
Martin Vyskocil 9Martin Vyskocil 9
Hi Tom, I have the very same issue and believe it's to do with renaming the app from "Salesforce1 for iOS" to "Salesforce for iOS". Hopefully the Trailhead author will update the unit soon.
Chris DuarteChris Duarte
Issue now resolved. Our apologies for the trouble.
Tom ButtTom Butt
Confirmed it's fixed. Thanks Chris.
Akash Lalchandani 5Akash Lalchandani 5
I am facing the same error, unable to complete this challenge.
Challenge Not yet complete... here's what's wrong: 
It doesn't appear that you've blocked all users' access to either the Salesforce for iOS or Salesforce for Android app. Please check again.

I tried doing this on both Android and IOS but it the error still comes up.
Below is the screenshot of connected apps with Oauth Access
You can clearly see I have revoked all the Android and iOS devices and hence it doesn't show up on the list.

Yuliana Westover 9Yuliana Westover 9
I can't complete this challenge either, I have the same issue as Akash. Is there a workaround? 
Chris DuarteChris Duarte
No, it should show up on the list, even if you've blocked it. Once you've blocked the app, you'll see an Unblock button next to it.

User-added image

The list shown in that screenshot shows that the apps haven't been installed in your Trailhead Playground.