function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Improve Data Quality for a Cleaning Supply App - Create a Formula Field : Challenge Not yet complete

I tried many times... but receive the same error message : "Challenge Not yet complete... here's what's wrong: 
Formula in custom field 'Account Annual Revenue' is not correct. Check the instructions."
I followed all instructions & get the right results. It's a basic & very simple formula.
Do someone else encounter the same issue ? Any solution ?
Best Answer chosen by Minkesh JAHERALY
I created a new Trailhead playground... entered exactly the same formula... and finaly could validated the challenge

All Answers

Frankie CollyerFrankie Collyer
I'm having the same issue. I've deleted the object and repeated the steps several times with the same outcome every time.
I created a new Trailhead playground... entered exactly the same formula... and finaly could validated the challenge
This was selected as the best answer
Frankie CollyerFrankie Collyer
It worked for me. Thanks for the help!
Bareera NoorBareera Noor
I am having the same issue . I am using the new trailhead playground but I am keep getting this error message. 

Challenge Not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: WFFNZIQU.

Nathan WylderNathan Wylder
I'm having the same problem. Have tried in different trailhead orgs to no avail. 
Nathan WylderNathan Wylder
I was only able to complete this stage by connecting a developer org to my trailhead account and then create the formula field in the developer org...please fix this trailhead team.
Robert BernhardtRobert Bernhardt
I had the same problem today, I tried to delete and re-add the formula field many time.  I followed the advice of the other users here.  Since I received the error in my development org, I just moved somewhere else - for me it was my trailhead playground.  Then it worked!
Pavlo ShchurPavlo Shchur
Hi everyone, switching to another Salesforce org helped me!
Marine Fabro 7Marine Fabro 7
I have the same problem... Tried it in many dev orgs... still not working !!!!!!!!! 
Marine Fabro 7Marine Fabro 7
I just did it in Classic and not LEX... and it worked...
Jenn RudigerJenn Rudiger
I just did it in Classic and it didn't work.
LaToya MaysLaToya Mays
I thought I was the only one having this issue. This is mind boggling...please help.
Brooks Johnson 6Brooks Johnson 6
Same issues. I have done this in a DE org and  trailhead playground both LE and classic. I still get an error. 
Venkata Naresh Thatha 8Venkata Naresh Thatha 8
I had issue in classic as well. Finally after switching to DE org, i could solve this problem .. Hope trailhead fixes this soon..
Jairo Straga 6Jairo Straga 6
I have been doing all my trailhead on a DE. For this one I switched to a Playground and it worked. Weird stuff going on but I solved it.
Iain MoneypennyIain Moneypenny
Failed on my DE but worked when I switch to an old and hardly used Playground. 
Connie Hazendonk 1Connie Hazendonk 1
How weird, I managed to indeed do this by linking a DE org instead f a trailhead org. Doing exactly the same. Thanks for the help!
Matt Larson Idea MachineMatt Larson Idea Machine
Improve Data Quality for a Cleaning Supply App - Create a Formula Field : Challenge Not yet complete


After having created a large amount of new playgrounds with no change, and realizing that I was living out the definition of insanity, I decided to approach the problem differently.

This solution is going to sound incredibly ridiculous, but if you are connected to a coffee shop wifi log out of your Trailhead and disconnect from the public wifi. I switched to my iphones hotspot, logged back in, clicked the verify button, and there was my 100 points of glory.
Jess BurghJess Burgh
Hey all! After a lot of frustration, I took someone's advice to try this step in Classic vs. LE. And it worked! 
Grzegorz Krawczyk 7Grzegorz Krawczyk 7
I just switched to a new playground and it didn't work. Waited couple of minutes and tried again only by clicking verify this step. And it worked! 

Sometimes, I think Salesforce intentionally throws these humdingers at us, as a test of our patience. Life isn't always fair, and complex systems don't always behave as you expect them to.

I tried switching from LEX to Classic, and that didn't work for me -- though I'm certain the formula is correct. Before running the test, I realized that this particular playground had "Activate Multiple Currencies" enabled (from a prior Playground module). I wonder if that is related?

User-added image
I moved to another (existing) Trailhead playground where international currencies was not enabled, and the test validated fine.

Maksim Kramer 14Maksim Kramer 14
Hey, folks. I've found the issue. You need add a blank space after the function "Account.AnnualRevenue" in the formula editor. The test developer forgot to use trim() function in the test
Not correct. Formulas ignore extra spaces. You can test this by editing that formula, adding a space after the argument, saving, and then editing again. You'll see that the space you added is now gone.
Andy Barnett 8Andy Barnett 8
This did not work the first time for me, even though I am quite certain I followed the instructions. Per suggestions in this post, I opened another Trailhead and was able to complete it the first time using the same steps I had followed previsously. Salesforce, please investigate. Something is incorrect here.
Mark Barcham 9Mark Barcham 9
Even creating a new playground won't sort this one.  Amazing that the Trailhead team haven't reviewed this module given there is clearly something wrong with it.
Alejandro Fernandez 29Alejandro Fernandez 29
I had the same issue and as someone said over here, changed to DEVELOPERS EDITION and it worked!! 
Jason FrizzelleJason Frizzelle
New Playground worked for me!
Alicia BrzeskiAlicia Brzeski
How is this working for people, I'm shocked? I've tried this in a new playground, in a new dev org. I even tried adding (), /, and spaces. Nothing is working. 
Gurpreet Singh 257Gurpreet Singh 257
Its generally working by changing to playground or your developer org because if you have done multiple currency challenge you have made changes to currency by adding euros so the conversion rates are applying while doing this challenge.