+ Start a Discussion
Steffen Brinkmann 15Steffen Brinkmann 15 

Trailhead Project : Build a Gauge Chart That Visually Identifies Regional Data

Hi Everyone!

When trying to veryfy the first challenge in "Upload Flag Images into Salesforce Analytics" I am receiving the following error,

Challenge Not yet complete... here's what's wrong: 
Could not find 'Analytics Cloud Platform' licenses. Please check instructions to login to Wave enabled org.

This is a brand new org. and setup as outlined on the trail.
The org. is connected and lunched - I have repeated this multiple times.

Permission Set Licenses

The error is talking about "Analytics Cloud Platform" licenses which indeed do not exist the licenses available here are "Analytics Cloud Explorer & Analytics Platform" which are Permission Set Licenses.

Any useful suggestion here is highly appricated.
Steffen Brinkmann 15Steffen Brinkmann 15
It's in the nature of an Technical Support Agent to figure things out by themself... It seems the the "brand new org." is simply too new. I found a 
workaround to pass the chalenge by using an older Analytics org. which I created a couple of weeks ago.

Permission Set Licenses - old org.

Here we can see the license is called slightly different perhaps Trailhead can take into consideration when updating or creating Trails and chllenges.
Susann LueckSusann Lueck
Hi guys,

I also have the same issue. Im not able to complete the the trail "Upload Flag Images into Salesforce Analytics", because "Challenge Not yet complete... here's what's wrong: Could not find 'Analytics Cloud Platform' licenses. Please check instructions to login to Wave enabled org."

My user looks like following. One thing is a bid wired - one permission set has no name. Maybe this is the error, but if I create new dev orgs I get always the same setup. How can this be solved? Unfortunately I don't have an old org which I can use to have a workaround like Steffen has.

User-added image

Puneet KhoslaPuneet Khosla
Any solution to this yet
Siddhant AryaSiddhant Arya
Me too facing the same issue.If someone could help, it would be great.
Kevin T. LeeKevin T. Lee
Having this exact same issue.  Wondering if the validation for the trailhead needs to be updated.  I've created 2 new orgs with the instructions and get the same error on both.
Cecillie ÆbeltoftCecillie Æbeltoft
Havig the exact same issue
Brad EndresBrad Endres
Glad to see its not just me. I created a new org for this as well, still getting error.
Claire JonesClaire Jones
Yes, I have the same problem too, including the permission set with no name
Puneet KhoslaPuneet Khosla
You have to use old Wave org as there is an issue with new ones.

Puneet KhoslaPuneet Khosla
Claire we meet again in dev forum :-)
Claire JonesClaire Jones
Just what I was thinking Puneet
 User-added image Hi!
Rebecca HendricksRebecca Hendricks

I have an org that I created almost a month ago (Nov 2017) and I'm still getting the same error with it.  If we need to use an org created before a certain time, then they need to state such in the training, or provide a way for those of us who joined afterwards to be able to complete this.
Gaurav Jain 7Gaurav Jain 7
Anyone find out the solution for this, i am facing same issue
Puneet KhoslaPuneet Khosla
Claire - Did you get me email?
Rebecca - The org needs to be pretty old (when they had old license names). I used an org which was created probably an year back

I have already raised this with Salesforce.
Karen MezatastaKaren Mezatasta
I am having the same issue.
Alan Thomas PayneAlan Thomas Payne
Anything new on this, I am having the same problem. With both new & old orgs.
Jeff DouglasJeff Douglas
Sorry all... this module is broken as of right now. We have a fix in place which will go out with our next release. Sorry for the inconvenience.

Jeff Douglas
Director, Trailhead Developer Advocacy
Karen MezatastaKaren Mezatasta
Hi Jeff.

Thank you for your response.  When is the next release?

Kasi ViswanadhamKasi Viswanadham

I am also facint same issue, can you please provide any solution.

Nikhil Jaitly 8Nikhil Jaitly 8
Hello All, I am facing the same issue again. Have the lens created in my dev org (multiple times, deleted and recreated multiple times, tried with different orgs and different browsers), still getting the error. The error sometimes say 'Polar Gauge Chart doesn't exist. Please check the instructions.' or 'A lense called 'worldwide_sales_with_flags' doesn't exist. Please check the instructions.'.

@Jeff Douglas, could you please help ?

Nikhil Jaitly 8Nikhil Jaitly 8
Lens in My org
Steve Holley EA TrailheadSteve Holley EA Trailhead
I too can't get past the error:
Step not yet complete... here's what's wrong:
Polar Gauge Chart doesn't exist. Please check the instructions.

Have tried saving the lens as worldwide_sales_with_flags, worldwide sales with flags & Polar Gauge Chart - and made sure twice I have followed the instructions to the letter ...
Reinhard MichelReinhard Michel
Same issue here as well always the same error message. 
"Polar Gauge Chart doesn't exist. Please check the instructions."
Michael LoweMichael Lowe
Hi Guys, so with the Summer release there is an updated syntax for the underlying config for this chart. So it will not be able to recognise your chart untill the trail has been updated. 
Rincy Isaacs 1Rincy Isaacs 1
Thius unit should be removed!
chris steele 25chris steele 25
Argh - this is the last unfinished unit of the last unfinished module/project/superbadge and the last unfinished trail for me. Once it is fixed I'll be a trailhead completionist! Just waiting for the fix from the good folks in Trailhead engineering...