+ Start a Discussion
Krishna MushamKrishna Musham 

Unable to complete Define Custom Big Objects task,

I am trying to deploy, big objects from workbench. 
By Using Examples mentioned in trail head, I cannot do the same in my org. 
I have followed all the proccess, Can Some help me here.. 
Alain CabonAlain Cabon
Hello,

Many people have problems with the deployment (not explained in the module)

Here is my technique:
https://developer.salesforce.com/forums/?id=9060G000000MSnUQAW

1) select "Single Package"  (and "Check Only" for verification without deploying)
2) package.zip  with three files and two folders (/objects/ and /permissionsets/ ) :
  1. objects/Rider_History__b.object
  2. permissionsets/Rider_History_Big_Object.permissionset
  3. package.xml
Alain
arpit vijayvergiyaarpit vijayvergiya
Hello Krishna,

While deploying make sure to check 'Single Package' and uncheck 'Check only' checkbox.
After this your object will apear in your org.

Mark it as best if it helps you.
Sunad RasaneSunad Rasane
worked on it for a long time.. follow steps properly..
1)Create xml file with name "rider_history__b.object" and not "Rider_History__b.object" uppercase willl make difference.
2) paste the following code in it.
 
<?xml version="1.0" encoding="UTF-8"?>
<CustomObject xmlns="http://soap.sforce.com/2006/04/metadata">
    <deploymentStatus>Deployed</deploymentStatus>

    <fields>
        <fullName>Start_Location_Lat__c</fullName>
        <label>Start Location Latitude</label>        
        <required>false</required>
        <type>Number</type>       
        <precision>7</precision>
        <scale>4</scale>
    </fields>
	
	<fields>
        <fullName>Start_Location_Long__c</fullName>
        <label>Start Location Longitude</label>        
        <required>false</required>
        <type>Number</type>    
        <precision>7</precision>
        <scale>4</scale>
    </fields>
	
	<fields>
        <fullName>Start_Time__c</fullName>
        <label>Start Time</label>
        <required>true</required>
        <type>DateTime</type>
		<unique>false</unique>
    </fields>
	
	<fields>
        <fullName>End_Time__c</fullName>
        <label>End Time</label>
        <required>false</required>
        <type>DateTime</type>
		<unique>false</unique>
    </fields>
    
    <fields>
        <fullName>Service_Type__c</fullName>
        <label>Service Type</label>
        <length>16</length>
        <required>false</required>
        <type>Text</type>
        <unique>false</unique>
    </fields>
    
    <fields>
        <fullName>Rider_Account__c</fullName>
        <label>Rider Account</label>
        <length>16</length>
        <required>true</required>
        <type>Text</type>        
    </fields>
	
	<fields>
        <fullName>Rider_Rating__c</fullName>
        <label>Rider Rating</label>        
        <required>false</required>
        <type>Number</type>
        <unique>false</unique>
        <precision>2</precision>
        <scale>1</scale>
    </fields>    
    
	<indexes>
        <fullName>Rider_History_Index</fullName>
        <label>Rider History Index</label>
        <fields>
            <name>Rider_Account__c</name>
            <sortDirection>DESC</sortDirection>
        </fields>
        <fields>
            <name>Start_Time__c</name>
            <sortDirection>DESC</sortDirection>
        </fields>        
    </indexes>
	
	
    <label>Rider History</label>
    <pluralLabel>Rider Histories</pluralLabel>
</CustomObject>


3)Create xml file with name "rider_history.permissionset" and not "Rider_History__b.permissionset" uppercase willl make difference.
4) paste the following code in it.
 
<?xml version="1.0" encoding="UTF-8"?>
<PermissionSet xmlns="http://soap.sforce.com/2006/04/metadata">
     
     
    <fieldPermissions>
        <editable>true</editable>
        <field>Rider_History__b.Start_Location_Lat__c</field>
        <readable>true</readable>
    </fieldPermissions>
     
    <fieldPermissions>
        <editable>true</editable>
        <field>Rider_History__b.Start_Location_Long__c</field>
        <readable>true</readable>
    </fieldPermissions>

    <fieldPermissions>
        <editable>true</editable>
        <field>Rider_History__b.End_Time__c</field>
        <readable>true</readable>
    </fieldPermissions>
     
    <fieldPermissions>
        <editable>true</editable>
        <field>Rider_History__b.Service_Type__c</field>
        <readable>true</readable>
    </fieldPermissions>

	 <fieldPermissions>
        <editable>true</editable>
        <field>Rider_History__b.Rider_Rating__c</field>
        <readable>true</readable>
    </fieldPermissions>

<label>Rider History Permission Set</label>


</PermissionSet>


5)Create xml file with name "package" and not "Package" uppercase willl make difference.
6) paste the following code in it.
 
<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>*</members>
        <name>CustomObject</name>
    </types>
    <types>
        <members>*</members>
        <name>PermissionSet</name>
    </types>
    <version>41.0</version>
</Package>

7) Create a folder named "objects" and not "Objects" or "object". Uppercase and s will make a difference.
8) Move the file "rider_history__b.object" in "objects" folder.
9) Create a folder named "permissionsets" and not "Permissionsets" or "permissionset". Uppercase and s will make a difference.
10) Move the file "rider_history.permissionset" in "permissionsets" folder.
11) add these two folders and file "package" in a zip.
12)now after adding these files the file name of "rider_history__b.object" in "objects" folder will have been changed to "rider_history__b.object.xml".
kindly remove the .xml from that file name.
13)the file name of "rider_history.permissionset" in "permissionsets" folder will have also been changed to "rider_history.permissionset.xml".
kindly remove the .xml from that file name.
14)goto workbench. select version 41.0. login. goto migration. deploy. add zip file.
15)Note uncheck "Check only" and check 'Single package'
16)deploy
 
Sam Derik 4Sam Derik 4
Hi Sunad Rasane,
 The naming is Case sensitive that's the reason I was unable to complete the challenge.
You helped me rsolve this.

Thank you,
Sam.  
Sam Derik 4Sam Derik 4
Sunad Rasane, I wish to mark your answer as best answer, Could you tell me how? 
Gabriel Patrick SalasGabriel Patrick Salas
OK so i was able to solve the problem declaratively WITHOUT workbench so fast.....here are the steps


1. setup - Big Objects
2. Click New to create a big object. 
3. and plugin all the challenge requirements manually rather than using work bench or xml files. 

this will literally take 5 mins lol 

this is by far the best answer. trust me.

you're welcome.