function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Albert MorganAlbert Morgan 

Failed Monitor and Manage Salesforce1 Usage

Challenge says "To pass this challenge, block all users' access to the Salesforce1 for iOS app or the Salesforce1 for Android app."

"Instructions say: From Setup, enter Connected Apps in the Quick Find box, then select Connected Apps OAuth Usage.
Click Block on the row for Salesforce1 for Android or Salesforce1 for iOS.
When you’re ready to reenable access to the app, click Unblock."

Now as  instructed in some other Challenge I have installed the Salesforce1 App on my Smartphone, which is an Android and have logged in and did looking around and stayed logged.

 From Setup, I entered Connected Apps in the Quick Find box, then selected Connected Apps OAuth Usage.
I only see Salesforce1 for Android as that is the only one I am signed into and so there is no Salesforce1 for iOS.listed.
I Clicked Block on the row for Salesforce1 for Android and I am promptly kicked off of my Salesforce1 App on my Andriod phone.
The option the Salesforce1 for Android nrow are UNBLOCK and UNINSTALL

So I run the challenge before unblocking the Andriod and it fails:

Challenge Not yet complete... here's what's wrong:
It doesn't appear that you've blocked all users' access to either the Salesforce1 for iOS or Salesforce1 for Android app. Please check again.

OK why is this ??  Is the challenge expecting you to have both an active Salesforce1 for iOS to block AND an active Salesforce1 for Android to block at the same time ??  That is not possible for me to do both at the same time.

I know I blocked the Salesforce1 for Android because I was kicked out of Salesforce1 on the phone and the Salesforce1 for Android wnet from users = 1 to users = 0. 
Kenichi ToumaKenichi Touma
*** English Version ***
I fall into a similar situation,
Although the cause is unknown, it was solved by the following procedure.

1: Login (Salesforce1 App on iOS)
2: Click the block in Salesforce for iOS row.
3: Execute challenge (fail)
4: Log in (Salesforce1 App on iOS)
5: Change the language of the login user from "Japanese" to "English".
6: Execute the challenge (success)

(After that, I returned the language to Japanese.)

*** Japanese Version ***

1:ログインする(iOSのSalesforce1 App)
2:Salesforce for iOSの行のブロックをクリックします。
4:ログインする(iOSのSalesforce1 App)

Sarah JohnsonSarah Johnson
Albert, I'm having the same issue that you had.  I can't pass the challenge despite knowing for a fact that I did as instructed.  Did you ever find a solution?
Albert Morgan 4Albert Morgan 4
Sarah, sadly I must report to you that have not been able to pass this challenge to this day and have never found a solution.  My questions has been posted out here out here in the Community for voer six months with only one Japanese response.  The sad part is since we can not complete the Failed Monitor and Manage Salesforce1 Usage Challenge we will never be able to complete the Salesforce1 Security and Compliance Module or Badge.  This is the last challenge that I need to pass to complete the entire module.
Sarah JohnsonSarah Johnson
Bummer!  I would at least like to know whether I'm doing something wrong or if it's a bug.  If it's a bug, I would think more people would have reported it.  Thanks!
Roger Chang 77Roger Chang 77
I'm encountering the same issue on my developer org. 
Tom ButtTom Butt
Under my list of Connected Apps I have "Salesforce for iOS" and this is the one I blocked.

The challenge error is that "It doesn't appear that you've blocked all users' access to either the Salesforce1 for iOS or Salesforce1 for Android app".

It makes me wonder if the missing "1" in my app is the cause of the failure.
Albert Morgan 4Albert Morgan 4
Roger and Tom join the crowd on this one.  Seems like after heariong from at least six different folks and there may be more that have not responed, I would think this is a SalesTrailhead bug.  But that is just me.
Roger Chang 77Roger Chang 77
My customer success manager suggested I submit a Case with SF for support on this trailhead bug. Guess what though, SF doesn't have a "Trailhead" or "Training" category to assign the ticket to:

I also posted a link to this thread over on the Trailhead community:
Roger Chang 77Roger Chang 77
Looks like I already received a reply:
"Chris Duarte (Salesforce)
Yes, unfortunately the name of the app changed with very little notice to our team, so we are making an adjustment and releasing an updated challenge, hopefully by the end of this week. You'll have to wait until then to finish the two hands-on challenges in this module. My apologies for the trouble.

Editor-in-chief, Trailhead | Salesforce"
Sarah JohnsonSarah Johnson
Thanks, Roger!  I appreciate the response.  It's great to know that they are aware and working toward a fix.  
Same problem here and I submitted a case to Support who didn't understand the problem at all. Good to know that it's just a matter of time now. I've been working at this all afternoon. 
Albert Morgan 4Albert Morgan 4
Mindi, yes I love it someone who finally responded to me from what I think might be trailhead support acted like I did nto have a clue what I was doing.  Told me to install the app on my phone.  Really ??  Told me to sign on to Salesforce1 with the same creditials that I use on Salkesforce.  Relly ??  Although I must admit his written communication was in very broken English, sometimes hard to understand clearly.  
Albert Morgan 4Albert Morgan 4
Ravindra Babu replied: Hi Morgan, Thanks for reaching us. Sorry for the delayed response. To see the option, you must log into the Salesforce mobile app with the same username and password where you are doing the challenge. For suppose, if you are doing this challenge in developer org, you need to download Salesforce mobile app and log into the mobile app with developer org username and password and then you can see the option as given in the unit. Please don’t hesitate to reach us if need any further assistance! Best Regards, Ravindra    
Chris DuarteChris Duarte
Hi everyone -- this issue should now be resolved. You should be able to pass both of these hands-on challenges in this module now:

Again, my apologies for the trouble.
Sarah JohnsonSarah Johnson
Thank you, Chris!  I was able to complete this challenge.  

However (and this might require a new post altogether), I am now showing a ton of incomplete trails that were previously completed after the recent updates to Trailhead.  Challenges are completely missing on modules I already completed the challenges for.  Heads up, in case your team doesn't already know about that.
Chris DuarteChris Duarte
@Sarah would you paste some specific examples please? I'm only aware of one - Lightning Experience Customization. Regrettably, it was published with a challenge missing, but we're getting it fixed in the next couple of days. You said there are a "ton" -- what other ones are affected?
Sarah JohnsonSarah Johnson
Well, I had a "ton" more trails showing as in progress that I'd already finished.  

1. Yes, the Lightning Experience Customization accounts for 2 of those. 
2. Another module that re-appeared as unfinished is here: ... which accounted for 2 more.  I was able to re-do both quizzes to re-complete those trails.  
3. And finally, one re-appeared because there is apparently a new module I need to complete, so I will do that:

Sorry to be so general before really digging in to the specifics. :)  With the fix for the Lightning Experience Customization, I should be all set.
Chris DuarteChris Duarte
Great, I'm relieved to hear that. Thanks, Sarah!
Yuliana Westover 9Yuliana Westover 9
Hi Chris, I am not able to complete this challenge. I am guessing the error message "It doesn't appear that you've blocked all users' access to either the Salesforce for iOS or Salesforce for Android app. Please check again." are there issues with this challenge again?
Chris DuarteChris Duarte
@Yuliana the challenge is working fine. I just did it in a fresh org in production and both challenges in this module are working correctly.

Here is what I did.

First, I installed the managed package into my Trailhead Playground to install the mobile apps. The managed package is located in this unit:

Here's the link to the managed package:

Then I did the challenge in this unit:
I set the Android app to need a 5 digit pin after 10 minutes.

Then I did the challenge in this unit:

To do this one, I installed the Salesforce app on my iphone, logged in with my Trailhead Playground username and password, and then blocked access to the Salesforce iOS app.

I passed both challenges with no issues.
Yuliana Westover 9Yuliana Westover 9
Hi Chris, I took the exact same steps you outlined and did not have any luck the first several times. I just checked the challange against my developer org where I had done all the work and it finally passed. 
Chris DuarteChris Duarte
OK I'm glad you made it through, Yuliana.