function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

workflow field update not triggering Process Builder

Hi All.
 I have a workflow which updates Field A to True and I have process Builder to execute when FieldA is true on Same Object .
 I have checked re-evaluate workflow checkbox but still process builder is not executig please let me know if i am doing anything wrong ?

Alba RivasAlba Rivas

I've tried to reproduce your case and it works for me.

What I have done:

- Create a workflow rule that sets a field to "whatever" on an object when a record is created or edited to meet the criteria. 
- Create a process in process builder for the same object, that when record changes, if field == "whatever" (criteria), posts to chatter.

It works fine for me, so check that you have both the workflow rule and process activated, because according to the trigger order of execution it should work, even if you don't check the "re-evaluate" checkbox.

Hi Alba ,

I am still not able to execute .

My Scenario

a) I have created A trigger which updating Account Number on Account Object 
b) Due to Step a) Field Update Workflow rule is Firing and Which is Updating Ownership to Public on same Account Object 
c) Now i have process builder on same account object which will fire when Ownership is Public which is getting true by Step b)  but still it is not firing .

I am still facing issue with this ! 
Alba RivasAlba Rivas
When you say you are changin ownership to public, what do you mean exactly? You can set up a user or queue on "Owner" field, but nothing that says "public". Maybe you are trying to change the sharing settings? Or is it ownership a custom field?
Ownership is delivered picklist field Ownership field
Dmitry Yudin 13Dmitry Yudin 13
Have you found any decision for this problem?
Well, if someone is using a time-dependent workflow rule to trigger the process builder, then it will not be triggered. There is a known issue reported in Salesforce. Link to the known issue. (
Ben Smith WFBen Smith WF

Alba and group,  I think I have a similar issue and would appreciate any insights.  I have an entitlement process that has two Violation Actions. An Email alert and a Field Update (Field to Update 'Case: DSG Notification count' Formula Value 'DSG_Notification_count__c + 1') .  Both of these actions fire off with no issue.  I have a PB that looks for "[Case].DSG_Notification_count__c IsChanged Boolean True".  With an action that adds a chatter msg.  If I manually edit the field I get my chatter msg, but if the entitlement process triggers the field update the PB does not flow.  Any thoughts as to what I may be missing?  I did try it with and with out "Re-evaluate Workflow Rules after Field Change"

Thanks,  Ben

Alba RivasAlba Rivas
I think you're facing an issue with order of execution. According to, entitlement rules execute after workflow rules / processes. Take a look at
Ben Smith WFBen Smith WF
Alba, thank you for your response.  I tried an additional timed rule 1 minute past the violation that updated another field and then a PB that says when fields X and Y are not equal to run the flow.  This also was not running.  Heard back from SF and it isn't an order of operations, but a known issue (bug) within SF.  
Field Updates triggered from Milestones on Entitlement Processes do not re-trigger Workflow rules

I do appreciate you commenting back and helping me dig deeper. 
Thank You!
Brooke Perry 8Brooke Perry 8
Ben, your last reply saved me a lot of time and effort! Thanks for returning to finish the thread.
Lewis HowelLewis Howel
Hi all, I think I have the same issue with approval process. I have technical approval that when approved, change approval status picklist value to Technically Approved. Then PB should fire on this change and submit for margin approval, but it does not. If i go and change this field manually though it does.
Jessica Clark 12Jessica Clark 12
Lewis, the problem you're experiencing is the same for me. Although, I'm using two process builders in congunction, and I'm not sure if there's an known issue with doing that.

Process builder 1: Update Related Contact Role (picklist field)
Process builder 2: When the Related Contact Role is updated, update an Opportunity field

Process builder 1 fires no problem, but it does not trigger Process builder 2. If I manually update the Related Contact record to match the criteria for Process builder 2, then it fires. 

Do Process Builders trigger actual update events? If they do, I personally believe they should be firing all automated processes after an update.