+ Start a Discussion

Avoiding the 'Open link in salesforce using mobile browser' for Customer Portal users using mobile devices./iPad

Hello everyone,
We use the Customer Portal with users using Customer Portal Manager Custom Licences who are set with Salesforce1 User = NO. uses use mobile devices such as iPad to access our portal.Our Customer Portal has VF custom pages, the first one being a component of the home page, right column.
Back to a few days, users could login and were accessing the Portal and embedded VF pages without problem.
Since the V40 (I guess), users are welcomed with these 'Open link in salesforce using mobile browser' pop-up. See link below
How can we avoid these? I looked everywhere and I could not find the answer.
Thanks in advance for your help,
Binu Moothedan 34Binu Moothedan 34
We are facing the same issue for one of our apps on the AppExchange that has a mobile component and this link was the only one that matched what we're looking for. Sad to see that there is no fix or response. I should perhaps raise a case with Salesforce to see if they have a solution or a workaround.
Hi Binu,  I believe this is a bug indeed. Sure, raise the case. Thanks, Jerome
Pawan Tiwari 14Pawan Tiwari 14
I am also facing the similar issue. I have a visualforce page which is accessed by a tab. When I click on tab , it always pop up with ''Open in salesforce using mobile browser'' message along with 'open' button. I am facing this issue only after summer 17 upgrade. I had the same code base but that works perfect on ipad with spring 17. Any workaround or help will be much appreciated.
Binu Moothedan 34Binu Moothedan 34
We found the fix. The fix was to add “iospref=web” to the URL of the survey URL. This was recommended by Salesforce through a support ticket I opened. I am waiting for them to confirm it is a supported approach but I expect it to be OK since they recommended we try it. Basically, the mobile app has to add this (iospref=web) on the URL request. Please try this and let me know if it does not work for you. It worked for us.
Pawan Tiwari 14Pawan Tiwari 14
Hi Binu,
Did you get any link or salesforce documentation for this(iospref=web) from salesforce support person.
Binu Moothedan 34Binu Moothedan 34
There is no documentation around this fix. In one of the case comments, the workaround suggested by Salesforce was to use the iospref=web parameter in the URL. @Pawan, is this not working for you?
Pawan Tiwari 14Pawan Tiwari 14
Hi Binu,
Thanks for your response. In my scenerio , I have a visualforce page tab , on click of the this tab I show some salesforce records. But unfortunately after summer 17 upgrade , I am getting 'Open in salesforce using mobile browser' messge in iPad. The iospref=web can not help in this because i get above message as I click on the tab.
Hello Binu, Pawan,
The iospref=web trick looks to work for me so far; Thanks for your help on this one,
Francis HartFrancis Hart
Hi All,

We also came across this issue back in Summer 17 GUS orgs and also found the iospref=web trick to fix the issue. However, it seemed that Salesforce patched the issue before the release of Summer 17 (somewhere around the 25th May).

Unfortunately, we have seen this issue rear it's head again in the Winter 18 pre release orgs, which again, the iospref=web fix seems to work.

It would be great if anyone has any idea if this will be again patched before release of Winter 18 or if the iospref=web parameter will be required from here on out.

Please see these two threads on the Salesforce Google Plus Mobile SDK community for more information, one is back in Summer 17 and the other addresses the current Winter 18 issue.

https://plus.google.com/103586382678382630964/posts/6Le6ytZ4uMg (Winter 18)
https://plus.google.com/100392209188467445997/posts/ECmeqey4Kzd (Summer 17)

Yup we are getting this in Winter 18 as well, who do we need to contact to get it fixed?
Ryan LancourRyan Lancour
For those of you who are experiencing this in the Salesforce1 browser UI, we've created a Known Issue to track affected cutsomers. Please reference that KI here (https://success.salesforce.com/issues_index?keywords=Winter%2018%20users%20shown%20brief%20Open%20link%20in%20Salesforce%20using%20mobile%20browser).