function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Priya Mukherjee 13Priya Mukherjee 13 

I have created an an Account named Goat Wranglers R Us and made Open Activities the first related list on the record detail page for accounts. Still getting this error

Hi Priya,

Could you provide the error details.

Shubham Panda 7Shubham Panda 7
i am also facing the same problem..
the error i am getting is like this:-
'' Challenge Not yet complete... here's what's wrong: 
The "Open Activities" related list does not appear to the first one on the Account record details page. Make sure that you are not using Record Types with Accounts as this prevents us from checking the layouts. ''
Miguel Bardos Jr.Miguel Bardos Jr.
I'm also getting the same problem. User-added image
Miguel Bardos Jr.Miguel Bardos Jr.
A teammate pointed out that I should be in the classic view; I was in the Lightning view. This solved the issue.
I am facing the same problem during solve this challange.. Please help me out if anybody can solve this-User-added image
Dhiraj AgarwalDhiraj Agarwal


You need to do some steps for the specified problem.

Click on Setup--->Customize--->Account--->PageLayout
After that you will see Account Page Layout, In that you have to click Edit and make sure that Open Activities comes / appear first if not then drag-drop it than save it.

Samuel IdemudiaSamuel Idemudia
User-added image

Yes, I am just coming up with this issue presently. I am getting the same error now and that is why I came to this community to find answers. Dhiraj Agarwal has been of tremendous help. Here is a summary of what I did to solve the issue.
1. First, it is adviced that you handle this challenge using the Salesforce Classic rather than Lightning Experience. So if you are on lightning, switch to classic to take on the challenge.
2. Next, click on setup at the top.
3. When you get to the Salesforce Classic Setup page, look on the left pane scrolling down till you find the "Customise". Click the arrow next to customise, click the arrow next to "Account" and finally click "Page Layout". This will take you to the Account Page Layout. This is just as Dhiraj Agarwal specified ===> Customize ---> Account---> PageLayout.
4. Click on "Edit" next to Account Layout. (NB: I first made an edit on Account (Sales) Layout but I didn't get the 500 points)
5. Create the "Goat Wranglers R Us" record and go get you new badge.

Also, you may have already created the "Goat Wranglers R Us" record and when you click on the "Check challenge... " it tells you " Could not find an account named 'Goat Wranglers R Us' ". Just like it did for me. Don't worry.

What I did was to delete the previous record I made and created another "Goat Wrangler R Us" record. 
But then again, I realised maybe I didn't spell Wrangler right the first time. I must have spelt it as "Rangler." lol.
Anyway.. I got a new Badge on Trailhead taking on this challenge.

I hope this helped?
Shout out to @Dhiraj Agarwal.

User-added image 
I followed all Samuel Idemudia's instructions above - but still gets an error message.  Can anyone please help?
khan Mohammed 5khan Mohammed 5
Navigate to Account Tab, then click  Goat Wranglers R Us record ......, then edit layout....Attached screenshot
Just Drag the Open Activity on top position. that's IT.
I did exactly above but same issue.
khan Mohammed 5khan Mohammed 5
Drag Open Activities to TOP Position 
Already Did Khan, but same issue.
khan Mohammed 5khan Mohammed 5
can u share error screen shot
Aditi JawalkarAditi Jawalkar
I have gone through all the steps... but still getting the error.
Is there any other Way to solve??
I was changed My trailhead playground and issue was resolved...
Devendra PatelDevendra Patel
removing of record types worked for me too
Michelle SchwemmerMichelle Schwemmer
I had the problem with the "Open Activities." Now it is saying:

"Challenge not yet complete in My Trailhead Playground 4
Could not find an account named 'Goat Wranglers R Us'."

However, I put "Goat Wranglers R Us" as an account name already so I'm not sure why it's giving me this error?
Souad AizelSouad Aizel
Hi All,
I was getting the same error. What I did is I used a different Playground and I completed the challenge in less than 2 minutes.