+ Start a Discussion
Guy HolmesGuy Holmes 

start routing with omni-channel unit trailhead solution

I'm having trouble on this solution as well.  I'm pretty sure I've completed all of the steps but am getting the
"Could not find a properly routed case. Ensure that you've setup Omni-Channel correctly by following the requirements."
error as well.  The issue I seem to be having is that after changing ownership of the case to the queue "High Priority", I am not getting a notification in the Omni-Channel widget box to accept.  It just says "You have no active requests".  Does anyone have any suggestions? 
Morgan Paradis 8Morgan Paradis 8
Same problem here
Leah SchneiderLeah Schneider
Did you set yourself to online in the widget box?  I had the same problem and that fixed it.
Luis Roberto Acosta CoronaLuis Roberto Acosta Corona
This is the best answer, when you set as online all works!!! User-added image
Morgan Paradis 8Morgan Paradis 8
Hey, I ended up just redoing the challenge. Honestly it was a while ago so I don't remember exactly what I corrected, but odds are you just missed a little thing. I thought it was easiest to start over and be very careful about details. Goes quick
Guys any idea why I cant get my case to appear in the widget? I have thorougly checked all the setup and seems correct https://screencast.com/t/aum9ZqASHEHx
Rick UptonRick Upton
Here are some things to check that helped me when I ran into this problem:
  1. Ensure that you have the "Service Cloud User" checked for your user.
  2. Log out of Salesforce and then back in again.
  3. Were the cases in the queue before or after omni-channel was configured? It appears that omni-channel ignores cases that were in a queue before it is configured for omni-channel, so try creating a new case and assigning it to the appropriate queue.
Still cant get it to work. I have completed all the other trailheads except this one. This is  my setup from the cases:
Fixed!!! in the service channel configuration when etting up the service channel, my salesforce object was set to "animal" instead of Cases. When I did. That fixed it
Kati Lillstrang 6Kati Lillstrang 6
I'm facing the same error message but not having the online widget box available. How do I get that?
Mujahid Islam KhanMujahid Islam Khan
I am unable to complete this challenge an dgetting below error

Challenge Not yet complete... here's what's wrong:
Could not find a properly routed case. Ensure that you've setup Omni-Channel correctly by following the requirements.

I think There may be a problem with last steps. Could you let me know what I have to do with below step.

Accept the case from the Omni-Channel widget, and leave it open in your console
Albane RigaudAlbane Rigaud

Hi, I have the same problem "Could not find a properly routed case. Ensure that you've setup Omni-Channel correctly by following the requirements."

In fact, I don't have any request in my Widget ... can you help me please ? Thank youUser-added image

Manoj Jain 13Manoj Jain 13
Hi Albane, 
I faced the exact issue today as mentioned in your comment. Later, I created a new Trailhead playground and did the exercise again from scratch (in Classic) and it worked perfectly. In the earlier instance, I started the exercise in Lightning and later swtiched to Classic midway. This might have been the issue I guess.
Best bet is to re-try the steps in a fresh instance and make sure you do it in Classic.
Hope this helps.

Dave HudnuttDave Hudnutt
Having the same issue identified in the last three posts. Unfortunatly, a new Trailhead playground didn't get around the error and I'm at a loss. No request comes through the widget to accept so the test doesn't see a properly routed case.

User-added image
Shawn Sabbini 4Shawn Sabbini 4
I have tried this module Three times now with the same problem.

The first indication of a problem occurs in the previous module, 

To re-create the issue:
Start with a new playground
Begin with the steps in "Understand Queue-Based Routing"
Enable Omni-Channel
Run Omni-Channel Setup from the tile under View All on the Service Setup start screen
Create a queue High-Priority Cases
enter a name for the permission set. Maria enters Tier1 Agents.  (We don't have this permission set setup though) It's meant to grant access to presence status later according to the mouse-over.
Add self as an agent to the queue
Skip step: Prioritize work for your agents, this screen isn't shown.
Leave defaults for workload 5 and 20
Finish.  All is OK "Understand Queue-Based Routing" is done, move on to the next module: "Understand Skills-Based Routing"

Enable Skills-Based Routing
Navigate to Setup > Omni-Channel > Skills.
Click New
The first indication of a problem - happened 3 times out of 3 attempts.   Get error:

New Skill
"Looks like there's a problem.
This record isn't supported. See your administrator for help."

User-added image

Try again and it will work.
Continue on with the module
Create skills for "English, French, and Spanish; for hardware technical support and software technical support; and for orders and billing"

go to Service Resource in Object Manager and select Page Layouts

The second indication of a problem.
Instructions are to edit the Service Resource Layout, but there are no page layouts at all here.  (3 time of 3 attempts)

User-added image

Potential problem number 3
At this point, no one has access to the Active field of the Service Resource object.

User-added image

We are going to need access and can grant it here and now, but it begins to look suspiciously as if the Omni-Channel system hasn't been initialized correctly.  Make it visible to all.  Same issue with other fields of this object: Account and Description.  Make these 2 visible to all as well.  Doing this for the first time this third attempt.

Create a page layout and move along.
Add the Skills Related List to the new page layout.

User-added image

Not feeling very good about how this module is going at this point.

Create Service Resources for Agents

Now, this third attempt getting this error:
User-added image

So try to re-login to the playground.  Launching from the bottom the module is bringing me to a login page rather than automatically logging me in.

Maybe there is a new issue going on at Salesforce or did I miss a critical step?

Any feedback would be welcome.  It's 11:20 pm Central time May 28 2019.

Originally started posting because of an error trying to complete the challenge for "Start Routing with Omni-Channel" and getting an error from the flow when creating a new case:  Error element myRule_1_A1 (FlowActionCall).
An Apex error occurred: System.QueryException: List has no rows for assignment to SObject 

But clearly, there are indications of a problem before that.  

Nicholas TurittoNicholas Turitto
I am experiencing the same things Shawn is describing. I have also tried in 3 different trailhead playgrounds and receive the same errors every time. All the same weird issues described above. The only thing I have to add is that when I attempt to create a new case at the end I get the following error: 
User-added image
"We can't save this record because the “Skills-based routing” process failed. Give your Salesforce admin these details. <b>An unhandled fault has occurred in this flow</b> An unhandled fault has occurred while processing the flow. Please contact your system administrator for more information. Error ID: 867393967-102760 (360893287)"
Wendy Legorreta 12Wendy Legorreta 12
I had this same issue trying to complete this trailhead. It would not let me save the case because it said the skills based routing process failed. I went into one of the already existing cases and edited the information to match the new case creation step in the trailhead challenge. I was able to save that cased I edited and completed the challenge. It's not ideal, but it helped me get past the challenge to move on. 
Florian W. WentzelFlorian W. Wentzel

I have the same issue... my "workaround" was to temporarily deactivate the Process Builder - Skills-based routing and then create the Case. 
Because the error points to the "flow" > Process Builder. I Think there is something in the APEX class missing...

This allows me to ent the trail, but I Know.... this is just a workaround.

Ramon PRamon P
The Apex code copied from this trailhead is searching a ServiceChannel with the DeveloperName = 'Case'. But following the trailhead, the ServiceChannel´s Developername created is 'Omni_Setup_Flow_Cases'. I changed the line 15 and it works for me.

Original line 15:
ServiceChannelId = getChannelId('Case'),
New line 15:
ServiceChannelId = getChannelId('Omni_Setup_Flow_Cases'),

Also, you must create and assign the "English" skill.

Hi Florian W. Wentzel!

Your observation was correct. I was able to create a new case after temporarily de-activating the process that was created for skill based routing.

Oladipo AinaOladipo Aina
Awesome response Ramon P, 

In my situation, I was working on one of the sandboxes. I was able to retrieve the right value for the channelName from Omni-Channel ==> Service Channels ==> Developer Name for the corresponding channel.

I also did same for skillName: Omni-Channel ==> Skills (select the skill) ==> Developer Name.

Jiacheng SunJiacheng Sun
 If the URL ends with .visualforce.com instead of .force.com, you need to whitelist https://*.visualforce.com in your CORS settings.
Xavier NXavier N
Thanks Ramon, your fix was the good one!
Robert Cameron GilbertsonRobert Cameron Gilbertson
Anyone running into the flow issue see Ramon's answer to fix the apex and assign the skill - thanks Ramon!!
Joseph Perez 8Joseph Perez 8
What I did and solve de problem, was, the Ramon step, change the apex code 
ServiceChannelId = getChannelId('Omni_Setup_Flow_Cases'),

Mari Vänttinen-KariMari Vänttinen-Kari
Thanks Ramon P for your comment on Sept 9, 2019! Your tip helped :)! - I don't know why I could not flag it as best ansswer. But it was!
Ajay Kumar 690Ajay Kumar 690
@Ramon P Your solution worked. It should have mentioned in TrailHead steps.
Lynn Phillips 7Lynn Phillips 7
So I finally figured out my problem where the case wasn't appearing in my omni channel widget:
On Omni Channel Settings I hadn't checked the box Enable Status-Based Capacity Model.  Once that was checked it worked like a champ.
User-added image
Billy SilvaBilly Silva
For those still lookig for a solution: Enable all presence statuses for your profile and enable presence based routing in omni-channel settings.
Salesforce does not see your change in presence status if you only enable one presence status:
User-added image
Clinton WalterClinton Walter
Go to Setup > Feature Settings > Service > Omni-Channel > Omni-Channel Settings. You can also go to Service Setup > Administration > Omni-Channel > Omni-Channel Settings or just type “Omni-Channel” in Setup Quick Search. Check the box to Enable Omni-Channel and click Save.

Oh God! its almost 2024 now and I got stuck in the same problem. After scrolling countless pages, creating dev orgs, playgrounds and viewing many videos I finally am able to resolve the issue. 
1. open the org both in classic and lightning
2. Create the case from classic.
3. update status for omnichannel to 'Available'
4. IMPORTANT - without changing to lightning, change the owner of the case you have just created and Viola!!