function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Emilien Guichard 40Emilien Guichard 40 

Build a Cat Rescue App That Recognizes Cat Breeds - Create and Train the Dataset error


I am stuck at the Create and Train the Dataset step on the Build a Cat Rescue App That Recognizes Cat Breeds Trailhead module.

I have successfully created the lightning component, uploaded the zip file and clicked on the train button but when I try to Verifiy I get the following error message:
"Challenge Not yet complete... here's what's wrong: 
Could not find a successful cat dataset training. The training may take a couple of minutes after the model is created."

Could you please advise ?

Thanks for your help.
Best Answer chosen by Emilien Guichard 40
Let's do a quick'n'dirty approach: delete and re-upload the dataset. Once you see the dataset labels with their respective numbers (like in your screenshot, you may have to "refresh datasets") run the training again. Wait approx. 1-2 min. Then verify the challenge.

All Answers

Can you please post a screenshot of the "Einstein Vision" tab? Also how long did you wait for the training - as the message says it can take a couple of minutes.
Emilien Guichard 40Emilien Guichard 40
Sure, here you go:

User-added image
also I did wait a few hours before tring to verifty the step again...
Let's do a quick'n'dirty approach: delete and re-upload the dataset. Once you see the dataset labels with their respective numbers (like in your screenshot, you may have to "refresh datasets") run the training again. Wait approx. 1-2 min. Then verify the challenge.
This was selected as the best answer
Emilien Guichard 40Emilien Guichard 40
Puurfect! It worked this time, thanks for the help.
I too get this error, I also get some lightning component load errors as I upload these dataset.
User-added image

User-added image
Aron Schor 24Aron Schor 24
MedhanieHabte try resaving the components in the prior units...I had the same issue.
Works for me!
lela tlela t
Hi, I tried saving back the lighting component, helper, apex class... deleting the dataset, uploading a new one, refreshing, clicking on train, waiting again... nothing! I always get the same error, which is impossible to interpratate. 

Also, I downloaded the zip file and we have those 3 folder 15 files each, so the Bengal folder instead shows up as if they were 14, I checked and there are 2 identical files in that folder ( different name, but same size and possibly they have the same md5 hash! 

I am not sure if this is related somehow to this issue, but it is quite annoying that we do not get a real advice on what is going on in this step.

@lela t:

When you look into the Lightning/Apex code of this step you'll see that a model training is executed. This needs to be finished as it's the precondition for a later image prediction. See also here the documentation for trainings (

When you execute this code as anonymous Apex code within your Developer Console you'll see in the debug logs the status of the model trainings. The training needs a status of "SUCCEEDED" with a progress of 1.0 (which are the exact counterparts of the response bode in the above mentioned documentation link).

EinsteinVision_PredictionService service = new EinsteinVision_PredictionService();
EinsteinVision_Dataset[] datasets = service.getDatasets();
for (EinsteinVision_Dataset dataset : datasets) {
     if ('Cats')) {
         EinsteinVision_Model[] models = service.getModels(dataset);
         for (EinsteinVision_Model model : models) {

The image duplication that you mentioned has no influence on this.

Resaved the components, replaced the code with a new copy/paste just in case I missed something, still doesnt work. 
@BillPowell__c What exactly "doesn't work"? If it's the training - what's the output of the Apex code as mentioned in my post from July 3rd?
Getting component errors when trying to import the dataset from the URL. Deleted the dataset (it manages to import after a few minutes anyway), I went in and ensured all the apex code was 100% precise from the module and resaved all, still doesnt work 
@BillPowell__c: Can you post the component error here?
User-added image
A shot in the dark - are you running Lightning Debug mode? If yes - does the error occur when you switch it off?
HA! That did it. Weird. Must have turned it on in a previous module and forgot to turn it off. THANK YOU!
Marcin TrofiniakMarcin Trofiniak

Similar like others i have problem with it. I am doing it same time with my friend who has same problem. We do al the copy/past staff create app upoad zip drom url and in this moment we sometimes get errors sometimes not... After it ulpoads i do train and refresh and ... nothing .... No Labels and can't pass the chalange... I checked debug i checked code ... Can't really find a rison why...


Answer after training


That what i get after trining... Wed for sometime and refreshing shows nothing new... Help me plis :)

Kyle O'Brien 7Kyle O'Brien 7
When I load the dataset, I get the "success" banner. However, in the developer console log I am receiving the status "attempt to de-reference a null object" - referring to this code snippet from the EinsteinVision_Admin.apxc:

    public static String trainDataset(Decimal datasetId) {
        EinsteinVision_PredictionService service = new EinsteinVision_PredictionService();
        EinsteinVision_Model model = service.trainDataset(Long.valueOf(String.valueOf(datasetId)), 'Training', 0, 0, '');
        return model.modelId;

Trailhead won't validate that I've finished this step because it can't detect the dataset having been loaded... Any idea what's going on here? I've re-saved all the of components/classes, deleted and re-uploaded the dataset to no avail. Also, despite it saying "success" there is no adjustment to the dataset models or labels columns. 

Carla Silvado 15Carla Silvado 15
I am having an issue with this challenge. My Einstein Vision tab will not load. I can click on it but I get an Internal Error message and then it keeps spinning. Any thoughts?
@Carla Silvado 15 - this can happen when you didn't set up the credentials correctly. Check out the possbile error logs in the Developer Console.
J C Shiva PrasadJ C Shiva Prasad
hey  guys when i put the URl and click create dataset nothing is happening can anyone suggest what must be wrong
Angelica Veness 12Angelica Veness 12
I'm getting this error message when I put the 'Einsteinvision_Admin_UI' component onto my new Lightning App. Then the same error if I try to go to the page.
User-added image
@Angelica Veness - Please check if you've set up the einstein_platform.pem file correctly.
Tuananh Vu 9Tuananh Vu 9
i'm getting the same error message like Angelica and i think i did set up the einstein_platform.pem file correctly. Anything else i could do?
David CantorDavid Cantor
I am also getting this error anything else to fix it??
Gurpreet Kaur 1Gurpreet Kaur 1
I want to use my own data set instead of the default one given in trailhead. I uploaded under files, generated the public URL and provided under Einstein Vision - zip file URL, hit create dataset, it's not doing anything. No error is displayed. Has anyone tried with own datasets?
@ J C Shiva prasad,

Did you get any response to your problem? I am also facing same issue.. Used the ZIP URL and clicked on 'Create Datasets'
Nothing happening.

Thanks in advance for any help 
Hiep LeeHiep Lee
@Gurpreet Kaur 1
I have tried the same as you and got the same result.
Sarah Woolley 5Sarah Woolley 5
Hi, I'm stuck at the same bit althoughit says success initially but then changes to FAILED  - 1% when I refresh ... you recommend to delete and try again - but I can't work out how to delete as the delete button does nothing...
User-added image
juan rodriguez 90juan rodriguez 90
Im stuck having this issue...

Unable to find action 'getDatasets' on the controller of c:EinsteinVision_Admin_UI

Can help me?

User-added image
Frank ReiterFrank Reiter
I cannot see a dataset after I try to create a dataset. I get no confirmation or anything else when posting the link "" into the field and pushing the "Create Dataset" button. 
I already re-edited and saved the contents of the module "Create a Lightning Component and Add It to a Lightning Page". 
After that I also re-created the Lightning App but I still don't see the dataset. 

My Tab looks like this: 

Dataset not visible
Ayushi Sharma 44Ayushi Sharma 44
User-added imageUser-added image
I am getting such errors when I drag EinsteinVision_Admin_UI Lightning component onto the Lightning page. What should I do?
Jessica Geutner 8Jessica Geutner 8
Hi I gut stuck here, could anyone please get me a hint how to resolve please? User-added image
Pinky ChaudharyPinky Chaudhary
Can anyone please tell me how long does t take to load the dataset, my data is loading for past half hour?