+ Start a Discussion
Karyna Woods 18Karyna Woods 18 

Trailhead - System.QueryException: List has no rows for assignment to SObject

Trying to complete "Community Rollout Strategy" and Create Sharing Rules Unit. Everytime I click on "Check Challenge", I get this error: 

Challenge Not yet complete... here's what's wrong: 
There was an unexpected error in your org which is preventing this assessment check from completing: System.QueryException: List has no rows for assignment to SObject

Any advice? Or do I have to start a new DE org? 
Getting the same problem. I'm wondering if there's some missing (or unstated) step in the challenge.
Garima Chaturvedi 4Garima Chaturvedi 4
Same problem. Please help.
This is now working for me as of this morning. Hopefully it will work for you as well.
Olivier FiquetOlivier Fiquet
Same problem, does anyone else has the same issue ?
Liqian zouLiqian zou
I had the issue because I was not using DE, but I was using playground. After switching to DE, and make sure your community active and published, it works for me. Hope this help you. 
João Amílcar Viana RodriguesJoão Amílcar Viana Rodrigues

Hello everyone,

I got the same error, and solved just including an image for each speaker from my list.
I finished it in a TP environment, by the way. It was not necessary to start from a DE org.

Godson GnanarajGodson Gnanaraj
Hi  João Amílcar Viana Rodrigues,
what do you mean speaker here?
Lovely Torres 3Lovely Torres 3

Godson Gnanaraj, 

João Amílcar Viana Rodrigues means to upload image files to all your speaker records. I created 3 speaker records so I uploaded 3 images for each

Ajinkya JagtapAjinkya Jagtap
Can you please explain how did you upload the images to the existing records in Speaker object? I am getting an error "Lightning components require My Domain. Please contact your system administrator for more information.". I am using developer version and not the licensed version.
João Amílcar Viana RodriguesJoão Amílcar Viana Rodrigues
Godson Gnanaraj,
"Speaker", the SObject related to the trailhead challenge.
junzaimon daimonzijunzaimon daimonzi
me to.
I cleared it after uploading images to all the speaker records.
Tejbir Singh 10Tejbir Singh 10
You can just check the debug logs about the missing part in your DE org.
Brandon Bridges 31Brandon Bridges 31

In my org I opened developer console and went to the logs tab highlighted in orange at the bottom of this image.

Then, when I run the assessment the error gets logged in the most recent log.

Then, scroll down to near the bottom of the log where you will see the error.

A little above that you will see the query that caused the error.

In my case, the assessment was looking for an opportunity named "Edge SLA" which I had deleted earlier. As soon as I created an opportunity with that name I passed the challenge.

User-added image