function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Unable to run the DataFlow(Default Salesforce Dataflow) and we can cant create a New Data set in our Wave Org

Hi Team,

We are trying to implement Wave in our Organization.

when we are scheduling the dataflow, it was trowing the errors as below,

There was an error executing the 109 node: Fields [X1st_Follow_up_date__c, No_of_Days_for_1st_follow_up__c, loan__NumberofLocations__c, loan__Primary__c, loan__ProductInterest__c, loan__SICCode__c, smagicinteract__SMSOptOut__c] are not available. Verify that the fields exists and that the Analytics Cloud Integration User profile has Read level access on the fields. (02K90000000TNNGEA4_03C90000000XcGcEAK)

We tried doing giving permissions and N no. of possibilities.

Can anyone help me to understand what was the issue and what should be done to resolve the issue???
NagendraNagendra (Salesforce Developers) 
Hi SujanSai,

This is generally caused by Field Level Security or managed package access.

Determine the related Object:
Retrieve the data flow JSON through the following steps:
  1. Gear Icon > Data Monitor
  2. Change view to Dataflow View
  3. Click the drop-down options on the right side for the target data flow and select Download
  4. Open the resulting file in your favorite JSON editor
Locate the specified node to determine the object, this will generally appear as follows:
"sfdcDigest_Node": {
    "action": "sfdcDigest",
    "parameters": {
      "object": "Object",
Confirm Field Level Security settings:
Review the Field Level Security for the Object within the Profile assigned to the Wave Integration User. Ensure the profile has Read Access on the field(s) listed in the error. More information about managing FLS can be found here:  Check Managed Package access:
Review the Custom Fields on the Object. Determine if they are part of a managed package.

Ensure that the Integration User has the necessary permissions and/or licenses to access the managed package that contains the target fields. Methods for granting access to managed package components vary, reach out to the package creator for assistance granting access to its components.

Restart Dataflow:
Once these items have been updated, you can re-run the data flow by selecting Start from the drop-down menu in the Data Monitor.

For Additional Reference check here: Kindly mark this post as solved if the information help's so that it gets removed from the unanswered queue and becomes a proper solution which results in helping others who are really in need of it.

Best Regards,
Heather WhamondHeather Whamond
When I click my gear icon, I don't have the Data Monitor option.  Do you know how I can fix this?
Naman Garg 22Naman Garg 22

I am getting the below error while running Dataflow set

Something went wrong while executing the Register_Account_Contact node: Error getting or creating container [error category: USER]: 202: The Dataset API Name can only contain underscores and alphanumeric characters. It must be unique, begin with a letter, not include spaces, not end with an underscore, and not contain two consecutive underscores.; 196763938-20311 (-630714228) (02K2w000001cY3fEAE_03C2w000007kSqSEAU)Data Sync isn’t scheduled for the SFDC_Local connection used in this job. Your data is only as up to date as the last manual sync. Schedule Data Sync from the Connect tab to make sure the job has the latest data.
Dropdown icon to open menu

Karan BhagatKaran Bhagat
Naman i have the same error did u find any resolution?