function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Joe Schmitt 10Joe Schmitt 10 

Admin Intermediate - Build a Suggestion Box App Adding Custom Fields Challenge error

I get this error: Challenge Not yet complete... here's what's wrong: 
The Suggestion custom object does not contain the correct set of custom fields. Tip: check for typos in the field names.

I've followed all steps, went back and rechecked, and then redid the entire challenge. I can't get it to pass. What am I doing wrong? I have included all custom fields and spelled them correctly.
Amit Chaudhary 8Amit Chaudhary 8
Can you please share the module link and your custom object screen shot with field
Ede J. HolmesEde J. Holmes
I have the same error. 
Module Build a Suggestion Box App - Adding Custom Fields Box Custom Fields
I've created the fields but Trailhead does not recognize them.
Error:  Challenge Not yet complete... here's what's wrong: 
The Suggestion custom object does not contain the correct set of custom fields. Tip: check for typos in the field names.
I copy/paste the field names and ensure the label/field name are correct.
I have to complete the training. Please let me know how to move forward. Thank you.
Same issue here, despite deleting and restarting the whole project, copying and pasting all names/labels etc from the Trailhead instructions rather than typing in (to remove the risk of typos), checking against any screen shots I can find online etc. It's still coming up with this same error, and it's preventing me from verifying the next steps of the project as well. Any help would be much appreciated please :)
amrutha kommuriamrutha kommuri

Hi, I have entered the same values in the picklist given in the module and followed all the steps. But, I am still getting the following error.
User-added image

Please help! 
Ede J. HolmesEde J. Holmes
I have submitted this issue via the tiny Feedbacklink at the bottom of Trailhead and forwarded an email with the details to my SFDC success manager. It seems difficult to find support for Trailhead.
Ede J. HolmesEde J. Holmes
@meganbacker @trailhead can you help with this issue? It seems a few of us have the same problem.
Barrie PotterBarrie Potter
I found the answer! Make sure you don't uncheck visibility for System Administrator 

Step 5: Add a Status field
9. Uncheck the box in the Read-Only column next to System Administrator, then click Save.

Step 6: Add a Date field
5. Uncheck the box in the Read-Only column next to System Administrator, then click Save.
Ede J. HolmesEde J. Holmes
Thanks, Barrie. I wish that would solve my problem but both of my fields are editable to the sys admin profile.
Chris DuarteChris Duarte
First, I'm sorry to hear some of you are having trouble with this challenge. I took the time this morning to go through the steps of this project personally and the good news is, it's worked as expected. There are a lot of configuration steps here, so it's important to make sure you've followed all of the steps as outlined. As I went through it myself, there were a couple of points where I had to go back and make sure I had unchecked and checked the right boxes. If you're still having trouble, send an email to trailhead at salesforce dot com. 

Ede, I just replied to your email personally. Let's see if we can't get this resolved for you.
Ede J. HolmesEde J. Holmes
Thanks very much for your help, Chris.
I found that I did not update the Field Names; something we rarely change in our real instance but clearly were asked to in this exercise. Once I had those updated, I was able to pass the module.
satya aryasatya arya

Anyone got solution for same? I am stuck in this module
Nayana SharmaNayana Sharma
Same issue...can anyone provide solution?
satya aryasatya arya
I tried it on different account. Still same problem
Benjamin Zurbrügg 1Benjamin Zurbrügg 1
Hey, I have the same issue. Here some screenshots. I tried it manytimes... :(
Hope someone can help, so I can finish this Trail. Thanks.
User-added image

User-added image
Fei (Kevin) XieFei (Kevin) Xie
Ok I found the solution.
I landed on this page because I had the same error message.
I verified all the field visibility and security settings and found one of my fields was not visible to System Administrator, I checked "visible" and I passed the challenge.
Perhaps Salesforce can make the error message more clear.
Nicole BellavanceNicole Bellavance
Hello, I am having the same issue. I have redone the exercise twice. reviewed my field security settings and all spelling. any suggestions ?
Shilpa KambleShilpa Kamble
I am having same issue, please provide the solution if anyone has resolved this problem.
amit kumar 430amit kumar 430
Fei (Kevin) Xie Thanks for the solution.
Fernando Morales OrtizFernando Morales Ortiz
Be sure you make all your fields visible to all profiles. In steps 1 and 2 it is stated that you leave visibility as is for both new fields but changing it to visible to all profiles fix the issue.
Palmira AngelovaPalmira Angelova

I am having the exact same problem. I have redone the exercise, gone back and triple checked everything (sys admin visibility, field names, check/uncheck boxes when creating fields line by line). At this point it's just a huge waste of time, but I need to pass. Given the number of people having issues with this, any chance there is a glitch? 

Anyone, help please! :'(

Michael CriswellMichael Criswell
The Suggestion Description field on Field Level Security leaves the Visibility unchecked for Admin by default. Make sure you check that for Admin.
Carlo Mora 1Carlo Mora 1
This worked for me! Thank you Michael!
Sherrie MooreSherrie Moore
I have tried all above suggestions and still cannot get it to pass.  Any other updates on this one?
Sherrie MooreSherrie Moore
I figured out what I was doing incorrectly; in schema builder  I was dragging Status and Implemented Date to the User object instead of the Suggestion object.  Maybe this will help someone else. 
Adrián JiménezAdrián Jiménez
I'm having the following problem. I get this error: "Challenge Not yet complete... here's what's wrong: 
The 'Number of Days Open' formula field did not return the correct number of days. Please recheck the formula." However, if I use the formula that is suggested, "IF(ISBLANK(Implemented_Date__c), TODAY() - DATEVALUE(CreatedDate), Implemented_Date__c - DATEVALUE(CreatedDate))", salesforce tell me there's a syntax error (Error: Incorrect parameter type for operator '-'. Expected Number, DateTime, received Date). I changed it by this one "IF(ISBLANK(Implemented_Date__c), TODAY() - DATEVALUE(CreatedDate), DATEVALUE(Implemented_Date__c) - DATEVALUE(CreatedDate))" and it is working now. However, when I try to Check the challenge I get the Challenge not yet complete error. Can you guys solve this issue?

Grant OngstadGrant Ongstad
Ok! I think I got it everyone! Make sure when you uncheck 'Read Only' for the admin, that 'Visible' is still checked. If you uncheck 'Visible', it automatically unchecks read only, which is what I didn't notice at first!. The visible checkbox must be checked for both the Implemented_date and Status, while the Read Only remains unchecked.

 User-added image
Mireille SigaMireille Siga
Hello all,
It is working! You have to check step by step any single field in order to set it perfectely. 
'Status'  and 'Implemented Date' fields: make sure when you uncheck 'Read Only' for the admin, that 'Visible' is still checked and follow the instructions
'Suggestion Category' and 'Suggestion Description ' fields : must have the default field visibility and security settings.
Manvita ParuchuriManvita Paruchuri
Hi, I tried all the suggestions and triple checked all the spelling but still seeing this!!

Step not yet complete... here's what's wrong:
The Suggestion custom object does not contain the correct set of custom fields. Tip: check for typos in the field names.
Joward CastilloJoward Castillo
If you think you've done the steps correctly, definitely review ALL your inputs (FROM THE START) because there's a high possibility you mistyped some of the details. In my case, I was having the same problem and I had to review my entries to find out that Field Name for "Suggestion Description" was missing the "n" so I had "Suggestion Descriptio" when I was having the problem. The moment I updated it, I passed the module.

Dane MorrisDane Morris
Good afternoon all,

I have just had the same issue. However, after reviwing the issue for... lets just say an embarressing amount of time. I realised that in Schema Builder, I dragged and dropped both the picklist and date into the USER object and not into the SUGGESTION object. Once I deleted both from user and added them to suggetion I passed the unit. 

I hope this helps.

Dane Morris
Ethan SeagravesEthan Seagraves
Guys, I think I cracked it, and it's a sneaky one. 

When you create the "Suggestion Description" box, you're asked to follow these Parameters:
Suggestion Description

When you create the field, Salesforce defaults the Field Name to SuggestionDescription.

Default Creation

Very sneaky, but you need to change this to an underscore in between.
Pranav ChitransPranav Chitrans
I answered on the below URL : 
Click me. (
J W 45J W 45
Hi Guys,
I used tips from Dane Morris and it worked. The reason is that the user object is immediately visible and the suggestion object is very small and you have to use the small map at the bottom right corner to find it.
Katarzyna JaroszKatarzyna Jarosz
Hi all,
Try setting Field-Level Security also for Suggestion Description. Set Visible for everyone and Read-Only for everyone except System Administrator.
It worked for me.
Celso D. OliveiraCelso D. Oliveira
Hi guys

I spent a long time looking for the error. And in the end I had just put the Data element inside the USER object, when it would have to be inside SUGGESTION, so if you are having the same error take a look at it.
Hi Guys,
Error Message : "The Suggestion custom object does not contain the correct set of custom fields. Tip: check for typos in the field names".
The real problem in this exercise is the translation : 'Statut' to put in English....Status !!! and Suggestion Category: Other (Autre), remove (Autre) !!!!
Have a good day,
Illiesse ChamsiIlliesse Chamsi
LAURE LARDET merci beaucoup pour ton aide.
Joel SigelJoel Sigel
I finally figured it silly. So when you clear the suggestions in the Schema Builder and select 'Suggestion' and 'User' it stacks them ontop of each other. So when you create these fields you are probably dropping them into the 'User' not 'Suggestion'. So simply click the 'User' object and drag it over. SIGH!!!!
Daya AbderrahimDaya Abderrahim
Hi ! thank you, everyone! I just figure it out! I I Set Visible for everyone and Read-Only for everyone except System Administrator.
It worked for me.
I had to go in and select Visibility for all and Read for all except System Admin for the Suggestion Description Field. It does not say to do this in the instructions except for the final two fields that you add from the Schema Builder: Status Field and the Date Field

While still in the Schema Builder, right-click the Implemented Date field that you just added to the Suggestion object. Click Manage Field Permissions.
At the top of the column, select Read-Only to make this field read only for all users.
In the Read-Only column, deselect System Administrator, then click Save.
Try Out the App
lekshmy puraniklekshmy puranik
Thanks Joel Sigel. It worked.... Make sure u drag into Suggestion box and not user box. It is hidden down the below.
Danyal lashariDanyal lashari
i have got this after lot of effort just check in systems administrator and status field visibility  it worked