+ Start a Discussion
Heather Young 12Heather Young 12 

DL Error while calling web service operation: login, error was: com.sforce.soap.partner.fault.LoginFault: null - Help

Hello, I am using data loader version 52.0 ( I have also tried earlier versions ) I keep getting this error : 2021-08-24 08:01:24,353 ERROR [accountUpsert] client.PartnerClient runOperation (PartnerClient.java:359) - Error while calling web service operation: login, error was:
com.sforce.soap.partner.fault.LoginFault: null. 



I have tried to run this with and encrypted pw, and an encrypted pw + token. 
Process config xml contains:

    <bean id="accountUpsert"
          class="com.salesforce.dataloader.process.ProcessRunner"
          scope="prototype">
        <description>Account Upsert bean gets the account record updates from a CSV file generated by a SQL SPROC and uploads them to salesforce using 'upsert'.</description>
        <property name="name" value="accountUpsert"/>
        <property name="configOverrideMap">
            <map>
                <entry key="sfdc.insertNulls" value="true"/>
                <entry key="sfdc.debugMessages" value="true"/>
                <entry key="sfdc.debugMessagesFile" value="c:\users\user\dataloader\v52.0.0\debug.log"/>
                <entry key="sfdc.endpoint" value="https://login.salesforce.com"/> ( I have also tried the exact name of our company instance)
                <entry key="sfdc.username" value=" myusername@mycompany.com"/>
               <entry key="sfdc.password" value="blabla"/>
                <entry key="process.encryptionKeyFile" value="c:\users\user\dataloader\v52.0.0\configs\dataLoader.key"/>
                <entry key="sfdc.insertNulls" value="true"/>
<entry key="sfdc.timeoutSecs" value="600"/>
                <entry key="sfdc.useBulkApi" value="false"/>
                <entry key="sfdc.loadBatchSize" value="200"/>
                <entry key="sfdc.externalIdField" value="a custom field"/>
                <entry key="sfdc.entity" value="Account"/>
                <entry key="process.mappingFile" value="c:\users\user\dataloader\v52.0.0\configs\test1map_wid.sdl"/>
                <entry key="process.operation" value="upsert"/>
                <entry key="dataAccess.name" value="C:\Users\user\dataloader\v52.0.0\CSVTEST.csv"/>
                <entry key="dataAccess.type" value="csvRead"/>
                <entry key="process.initialLastRunDate" value="2005-12-01T00:00:00.000-0800"/>
            </map>
        </property>
    </bean>
</beans>
I have also tried with full config.properties and an empty one. 
Any tips or help would be greatly appricated. 
Thanks, Heather 


 

SwethaSwetha (Salesforce Developers) 
HI Heather,
Can you try adding a security token to the password?
Recommend reviewing similar posts:
https://trailhead.salesforce.com/trailblazer-community/feed/0D54S00000A9C2hSAF
https://salesforce.stackexchange.com/questions/218794/dataloader-command-line-error

Hope this helps you. Please mark this answer as best so that others facing the same issue will find this information useful. Thank you
Rajesh Kanike 14Rajesh Kanike 14
I had similar issue but its fixed now.

   <entry key="sfdc.password" value="blabla"/>
I followed below steps for sfdc.password Value 

<path to key file> = C:\DataAutomation\Key

Generate a key: -k <path to key file>
              Generates a key file with random text
encrypt -e <password+secret token> <path to key file>
        password and Secret token is NOT saperated

result of encrypt command is sfdc.password Value. Hope this helps