function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Priya Grewal 6Priya Grewal 6 

flow screen duplicating

I have a flow that seems to run pretty smoothly, but for some reason with a few accounts, I get this error.
Not only that, it meets requirements to go to the next steps through the flow, but instead brings me back to the same screen, but duplicated at the bottoms. This is not how it was built and nor is the screen built like this.

Pictures below. I have highlighted in red what the original screen contains.
Has anyone had this before and how could I fix this?

User-added imageUser-added imageUser-added imageUser-added image
AbhishekAbhishek (Salesforce Developers) 
Priya can I have the Org so that based on the error ID -1820005570 I wil checked and give more info.

Salesforce support
Priya Grewal 6Priya Grewal 6
Hi Abhishek
It's: 00D8E000000FSfG

Thank you
AbhishekAbhishek (Salesforce Developers) 
Priya below is the details I can provide you max.

S1 UI Platform ClientSidePresentationException Error in serviceComponent://ui.interaction.runtime.components.controllers.FlowRuntimeController/ACTION$executeAction ( DeviceType: LARGE AppName: one:one)

lib.gack.GackContext: java.lang.IllegalArgumentException: unable to find element for complex reference: Get_Opportunity.Occupancy_Status__c

If you find the information helpful mark it as the Best answer.
Priya Grewal 6Priya Grewal 6
Hi Abhishek,

unfortunately not. That doesn't even relate to the actual section of the flow. 
Priya Grewal 6Priya Grewal 6
I have also tried removing the get_opportunity.Occupancy_status_C from the flow and it still has the same error.
Rachel Palmer 7Rachel Palmer 7
Priya, were you able to get this resolved? I am currently encountering the same issue.
Priya Grewal 6Priya Grewal 6
Rachel, unfortunately not- I even tried recreating it, no idea where the issue was. I had to change the process and where things happen for it to work.
Rachel Palmer 7Rachel Palmer 7
Hi Priya,

Thanks for the response. It seems like you've already found a workaround, but in case it's helpful for you, I posted about a similar flow error, and someone was able to track the error back to userLocation: 

While I don't reference userLocation in my flow, I had an assignment at the beginning that retrieves {!User.Email} and stores it in a variable to later  retrieve all records with that email. I changed this so that the user types their email address in an Email field, and then I use their input to pull records with their email. For now it seems to have solved my problem, and although I'm not quite sure why, referencing User was the issue for me.
Priya Grewal 6Priya Grewal 6
That is really odd as I had no reference to email. When I did a few tests I had noticed it was always when it had to update another record with a checkbox=true. What I did to counteract that is update the record at another stage of the flow which fixed it. No idea how that made a difference. Email: Web: