+ Start a Discussion
Ron LisleRon Lisle 

snapshotViewCreationHandler stopped working in SDK 9

We have been using snapshotViewCreationHandler in the iOS SDK to display a splash screen before going into the background. This has worked until we upgraded the SDK to 9. Now the handler is never called. I tested rolling back to SDK 8.1 and everything works with that version. Is this a known bug in SDK 9, or is there a different API I should be using?
AbhishekAbhishek (Salesforce Developers) 
Ron,

If it suddenly stopped working means you have to reach salesforce mobile support for official clarification.

https://developer.salesforce.com/docs/atlas.en-us.mobile_sdk.meta/mobile_sdk/gs_whatsnew.htm

Check this also once.
Ron LisleRon Lisle
Thank you. I've verified that snapshotViewCreationHandler is not listed on the deprecations page. My code compiles, so it hasn't been completely removed, its just not being called. I also tried setting useSnapshotView to true (it's default state) and that didn't help. I've posted over on salesforce.stackexchange.com with the mobilesdk tag, and will see if that gets any traction.
wood lariwood lari
We have been using snapshotViewCreationHandler in the iOS SDK to display a splash screen before going into the background. This has worked until we upgraded the SDK to 9. Now the handler is never called. I tested rolling back to SDK 8.1 and everything works with that version. Is this a known bug in SDK 9, or is there a different API I should be using?
its all also with us and now it (https://talosdrones.com/product/dji-phantom-4-multispectral/?fbclid=IwAR0K9THTMYvZ89aYLRlWhcye0BwnyhXzguIT-SlfzM5AGHCOq3VHkNHZqrI) good