+ Start a Discussion
Lavinia CiobanuLavinia Ciobanu 


Hi everyone!

I have an issue and I cannot figure it out what's the problem.
I have created a flow for changing shipping method and updating delivery address. When I run the flow with my system administrator profile everything goes as expected. When I try to run with a supervisior profile I have an issue when it tries to update some fields on OrderDeliveryGroupSummary Object and I have this error: : INVALID_FIELD_FOR_INSERT_UPDATE: Unable to create/update fields: DeliverToCountry, DeliverToCity, DeliverToName, DeliverToState, DeliverToPostalCode, DeliverToStreet. Please check the security settings of this field and verify that it is read/write for your profile or permission set

The problem is that I checked the object permission for this profile and it has the same permission as a system administrator. I gave access for everything this flow needs. These fields are not visible in the object because they are address type I believe, they are visibile only in Workbench, so I can not give access directly to these fields, but it's the same for System administrator and it works. How to solve this issue? Please help

Thank you!
ShivankurShivankur (Salesforce Developers) 
Hi Lavinia,

It looks like the user or profile is missing FLS/access related to fields from the object OrderDeliveryGroupSummary.If its not the address fields, then it could be any other fields which gets modified where the user doesn't have access to. Since , admin would have Modify all permission it could work fine, but with this profile, you might want to check other fields too which gets updated in the transaction.

Similar discussions:

Hope above information helps. Please mark as Best Answer so that it can help others in future.


Lavinia CiobanuLavinia Ciobanu
I have the same access for these objects and fields as a System Administrator. I checked all of them. That's weird.. 
Deepak KalaDeepak Kala
Hi Lavinia,
Plz assign Flow access to a User with Supervisor profile from user setting. Check if it works for that user.

Veronin SkadvizVeronin Skadviz
Can we transfer these data from Mac to a Windows PC using an app like Transmac
Lavinia, I had the same issue with a field in my flow that would not update, throwing that same error.
  • My fix was the Field Level Security (FLS) on the field(s) for that users profile
  • I found that FLS was not checked - an easy fix!
  • What pointed me to the fix was that I noticed the field missing on the user's page