function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Bryan Leaman 6Bryan Leaman 6 


When I try to use Async SOQL I'm getting an error that I have insufficient access to query this object ... with Async SOQL.  The Id provided in the error starts with "01I" and I cannot determine what this is. I'm a full system admin.  

I found posts from 2017 & 2018 that Async SOQL was a pilot program that needed to be enabled in the org.  We're halfway through 2021 -- is this still only a pilot program feature???
ANUTEJANUTEJ (Salesforce Developers) 
Hi Bryan,

>>Version: 41 -

>> Version 43:

I see that on changing the api version to the previous ones the async soql documentation is available version 41. From version 43 the message mentioned in version 41 i.e., "Async SOQL for standard and custom objects is in Pilot." is removed can you try checking the above links once?

Let me know if it helps you and close your query by marking it as the best answer so that it can help others in the future.  

Bryan Leaman 6Bryan Leaman 6
I was using API v 51. I tried v43 and I get the same error message. I tried changing my targetObject to a big object and I still get the same error.
Bryan Leaman 6Bryan Leaman 6
Hmm. somewhere along the way I thought I saw that standard and custom objects were supported with Async SOQL, but it turns out that the v52 docs say the "from" object must be a Big Object.  That's too bad, as it's a simple query on a custom object that it timing out on me.