function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Devin CormierDevin Cormier 

error when deploying: No source backed components present in the package

Using VS code trying to deploy the objects folders I get this error.  Not sure what it means or how to resolve.  Internet doesn't seem to  have much in the way of references to this term.
SwethaSwetha (Salesforce Developers) 
HI Devin,
Which version of SFDX are you using? Can you try another version to see if it fixes the error? Thanks
Devin CormierDevin Cormier
I just successfully updated the version: sfdx-cli: Updating CLI from 7.107.0 to 7.107.0-621a7d2.

Getting the same error in vs code.
Jakub JaworskiJakub Jaworski


Just have tha same issue with deploying profiles/ folder. Version update didn't solve the issue.

SFDX version:
sfdx-cli/7.108.0 win32-x64 node-v14.17.1

Thanks in advance for any help on that.

Corey WelchCorey Welch

This appears to be an issue with the Salesforce CLI Integration plugin for vscode after v50.x. I downgraded the plugin to v50.17.0 and this solved my issue.
Devin CormierDevin Cormier
Thanks for the help
Rajesh NVRajesh NV
i'm stil facing same issue while deploying to Org, even after downgrade the plugin to v50.17.0

Any help would be appreciated please
Michael Steg 22Michael Steg 22
So for me this error "No source backed components present in the package" was from an actual error in the code 

I copied my class into developer console and when I saved the error displayed - when I cleared the error (in my case the closing braces was in the wrong place) then I could save the class, retrieve the update into VS Code and deploy from vs code back into the org with the updated code

For whatever reason the error in developer console did not display in vs code (i.e. intellisense)
Andrii Lavreniuk 9Andrii Lavreniuk 9
I'd recommend checking the syntax and formatting of package.xml. It is possible that you missed the closing or opening tag
Pee Jay CadungogPee Jay Cadungog
Check your component's API name because VSCode is case-sensitive. What's weird is, retrieving the components is not case-sensitive but when deploying it is.
For me it was an uppercase letter in the name that was actually lowercase, thank you Pee Jay