function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Brian KesslerBrian Kessler 

Prepare Your Combined Data in a Recipe: Error PFJYMSYV

I am almost finished with the Integrate Local and Remote Data in Einstein Analytics ( project, needing only to complete the 
Prepare Your Combined Data in a Recipe ( Unit.

On my first attempt, I know I am responsible for fucking things up because I accidently named the recipe "North America Sale" and Salesforce/Wave/Einstein doesn't provide adequate tools to rename this to "North America Sales"..

Rather then redo everything, I tried to be clever: I downloaded all my metadata to IntelliJ/Illuminated Cloud and then tried to make the required chantes to src/wave/North_America_Sales.wdpr, but I couldn't upload the results because
23:41	Deployment Failed
			ERROR deploying WaveRecipe wave/North_America_Sales.wdpr: A Recipe must specify a Dataflow

23:41	Deployment Complete: Deployed 0/1 components to DTCElectronics in 1 s 311 ms with status FAILED.

After struggling for some time to find a way to make this deployment work, I eventually conceded it may be faster to just recreate the recipe.

So, I deleted the "North America Sale" receipe from Einstein Analytics and did it again, being extra careful to name it ""North America Sales".

However, now when I click "Verify step to earn 100 points", the result is:
Step not yet complete in
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: PFJYMSYV

What is going wrong?
Is there any way I can get this to work without starting from scratch?
If so, how?

NagendraNagendra (Salesforce Developers) 
Hi Brian,

Sorry for this issue you are facing.

May I request you please confirm if you are using a brand new developer org in order to validate this challenge, if not then I would suggest you create a brand new org and give a try which should probably do the trick.

If you are using a brand new developer org then please double check that your org doesn't have a namespace enabled. If that doesn't help please give a try by restarting the batch.

If the problem continues,  log out of all accounts and log in once again in a different browser by clearing the cache and cookies which should probably do the trick.

Hope this helps.

Kindly mark this as solved if the reply was helpful so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Brian KesslerBrian Kessler
Hi Nagendra,

Thanks for the canned response.
I very explicitly was asking how NOT to start from scratch: I was on the LAST damn step.

I was using TWO new developer analytic orgs.
Why on earth would anyone who followed instructions that far into the Trailhead suddenly have namespace enabled?

Anyway the problem was "solved", though with more reworking than I prefered.
I needed to delete the "North America Sale" dataflow separately from the "North America Sale" recipee AND then after BOTH were deleted, recreate BOTH.

There should be a non-destructive way to do such things, but I didn't find it.

Robert NoceraRobert Nocera
I am facing the exact same issue (except originally I named mine "North American Sales".  Even though I have deleted and recreted the recipe, renamed the recipe, duplicated and renamed the recipe, when I try to verify it to my my last 100 points it says it cannot find "North America Sales" recipe.  Anybody find a solution?