function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Tanveerr Ahamed T ATanveerr Ahamed T A 

Error: Salesforce CLI is not installed. (Integrating VS code with Salesforce)

I tried integrating Salesforce with VS code.. I installed Salesforce CLI and when I tried creating a project in VS code but it says that Salesforce CLI is not installed.
 The exact error is

"14:48:25.402 sfdx force:project:create --projectname TestProject --outputdir d:\ --manifest
'sfdx' is not recognized as an internal or external command,
operable program or batch file.
14:48:25.492 sfdx force:project:create --projectname TestProject --outputdir d:\ --manifest ended with error spawn sfdx ENOENT
Salesforce CLI is not installed. Install it from"
Khan AnasKhan Anas (Salesforce Developers) 
Hi Tanveer,

Greetings to you!

Please refer to the below links with a similar discussion which might help you further with the above issue.

Also, Java is a pre-requisite. See the detailed instructions on how to setup VS Code for Salesforce:

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
dymocks buildingdymocks building

If you are looking for the best services and shopping sydney centers then you are right place with The Dymocks Building. Visit The Dymocks Building, a historical place located in the heart of Sydney CBD. Here you will find the lawyers sydney CBD, insurance brokers sydney CBD, real estate sydney CBD etc. For more information visit our website.
Charissa JelliffCharissa Jelliff
Hi Tanveer,

Were you able to get something to work? I've been having the same issue and cannot find a solution. I've installed Java, I've uninstalled and re-installed the CLI, I've updated the Path, and still no joy. 
Basil DobekBasil Dobek
I hit this error when I had the 32 bit Salesforce CLI installed but the 64 bit VS Code.  Reinstalling Salesforce CLI didn't correct issue, I had to uninstall 32 bit before installing 64 bit version. 
Omar Aldawud 6Omar Aldawud 6
You need to add SFDX location to the System Path Variable (not your own variables). open Environment Variables and set the path in the System Variables section as highlighted below:
Windows Environment Variables
Carly Probasco 14Carly Probasco 14
I'm also trying to create a project for the first time and receiving the error above saying the CLI isn't installed when it is.  I have the the CLI path listed under User Variables. I've reviewed the links above to no avail. HELP!
Omar Aldawud 6Omar Aldawud 6
From command line run echo %PATH% and ensure that PATH value shows something like ....\Microsoft VS Code\bin at the end.  If  not repeat steps above.
Hun LowHun Low
I had the issue as well, many people were talking about setting the path, yes they are correct, but no use having the correct path if you do not have everything installed, eg SFDX commands are not installed.

I think most people have single line installed so installing Visual studio code was no issue for them.

I have included the sites. I am using Windows doing a clean install.

I assume you have Java JDK 8 installed (ignore other versions 11,13 , etc, even if you have it installed you still need 8 installed)

1. Install Visual studio code (" target="_blank)
2. Install the extension pack for Salesforce. This is the extension enables the visual studio to use SF commands to work on your SF codes, etc (" target="_blank)

Does not mean the commands are available, that is why you are getting the error, see below.

3.  Now finally install Single command-line interface for and all Salesforce DX features. This is where you point your "PATH" too after install. Infact the program automatically installs the path for you, if not follow the steps of other people comments above. (" target="_blank)

4. Finally Restart PC!!! Windows refreshes the path only after restart, even after you edit and save.

Regads Hun
Hun LowHun Low
Hi Again, please select like if it works for you.

Regards Hun
Hun LowHun Low
Hi Again

I installed the Visual Studio Code 64 bit, Apparently it is now recommended to use Java version 11, make sure you get the 64 bit version as well.

Otherwise running you APEX code will not work.

Cheers Hun
archana kumari 46archana kumari 46
h team,
Did this issue got resolved .I amfacing the same issue
I was also facing same error. I had followed these instructions ( to reslove this.
Sudharsan C 26Sudharsan C 26
Hello All,

I installed my VSCODE in my machine 
I installed the CLI 
I installed the extension pack(Salesforce CLI and Lightning web components)
I have JDK 

When i create a project with manifest i clicked STANDARD and named a project name and saved in a local. But Project not created and its running more an hour. NO ERROR in the terminal and problems. What is the issue? Can anyone please guideme.
User-added image
Karansingh KunwarKaransingh Kunwar
Hi @Sudharsan C 26 follow instrunction from Hun Low, it solved same isssue for me.
Pravudatta MohantyPravudatta Mohanty
in npm\node_modules\sfdx-cli\bin folder, rename run.cmd to sfdx.cmd
James Tran 6James Tran 6
Thank you Hun Low for your solution.
I got the same error so here are the steps I did.
Installed Java 8
Downloaded and Installed salesforce CLI 64-bit. Ignore the message that CLI was already installed with the sfdx package
I didn't have to manually insert the CLI path into the system PATH
Restarted my pc and it worked fine.

Hun LowHun Low
@James Tran and all

Glad I can help. Usually next you want to download saleforce code and config, that means "authorizing an org", this may also help if you have port or IT network issues.

abhishek Tomarabhishek Tomar
If you have already installed the salesforce cli in your system and you are still getting this error. Go to advance system setting > Environment variable > system variable > Edit the path variable and add your salesforce click on OK > Restart your pc > open your cmd prompt and enter >  sfdx update.
Ishan Grover13Ishan Grover13
Guys just Restart your machine. Everything will work fine
Piruthiga KPiruthiga K
@Omar Aldawud 6 It worked for me. Thankyou