function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Differently formatted XML from mdapi:retrieve and source:convert?

Is anybody else experiencing differently formatted XML from the following two commands?
  • sfdx force:mdapi:retrieve
  • sfdx force:source:convert

Ideally, if do a (1) mdapi:retrieve, then a (2) mdapi:convert, and then a (3) source:convert, the outputs of the first and third commands should be exactly the same.  However, I am seeing that the XML file outputs are different.  Mdapi:retrieve outputs "'", while source:convert outputs "'".  Mdapi:retrieve sometimes outputs a extra newline at the end of a file that source:convert does not.  And they sometimes output XML nodes in a different order from each other.

I have resolved this problem through code.  I'm wondering if anybody else has experienced this difference and what you are doing about it.

Michael DiggerMichael Digger
I have the same XML bug on my website detecthistory ( about metal detecting. Have you solved this problem?
@MichaelDigger> "I have the same XML bug on my website ****** (https://**********.com/) about *******. Have you solved this problem?"

Your website appears to be a WordPress website, and therefore it seems highly unlikely that you're experiencing the same problem.  I'm flagging your post as "spam", but if it truly isn't, please provide us with further detail.