+ Start a Discussion
Stefano AmentaStefano Amenta 

Data Loader Login Error

Since I changed to a new laptop (Win 10 machine) I'm unable to login to the Data Loader.

I always get this error message with any of my usernames.

Do you know how I could fix it?

User-added image
Did you try OAuth?

Also, just in case if you missed this - https://help.salesforce.com/articleView?id=000324395&language=en_US&type=1 (https://help.salesforce.com/articleView?id=000324395&language=en_US&type=1)
Stefano AmentaStefano Amenta
Hi Apuroop Naidu

I tried with OAuth but same problem.

I reviewed the article but it doesn't seem to apply to my case. I'm sharing the same network with other colleagues and they are able to login the data loader.
Stefano AmentaStefano Amenta
I'm using DL version 45.0.0
Try logging into this - https://dataloader.io/

Let's see if you're still getting the same error.

Also, in that link above, number 3 looks like your case?!
Stefano AmentaStefano Amenta
I have been using dataloader.io so far and I can login without issues.
We aren't using a proxy in our network.
I know you must've tried this but can you try using this URL - https://<YOUR INSTANCE>.salesforce.com
Stefano AmentaStefano Amenta
Tried with my instance but same problem.
Khan AnasKhan Anas (Salesforce Developers) 
Hi Stefano,

Greetings to you!

This might be IP Whitelisting problem. If you do not have IP Whitelisting the password should be a combination of Password + Security Token. Check your login history, you probably need a security token reset.

To reset it:
Click your profile icon -> Settings -> My Personal Information -> Reset My Security Token

User-added image

When you get your token, try to log in to the dataloader. Your password will be Password + Security Token: yourpasswordXXXXXXXXXX

Also, if you are connecting to a Production/Developer instance, the URL should be: https://login.salesforce.com
If you are connecting to a Sandbox, the URL should be: https://test.salesforce.com

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Stefano AmentaStefano Amenta
Hi Khan,

I checked my urnames in each org, but I can't find "Reset token" in my personal settings.
Khan AnasKhan Anas (Salesforce Developers) 
Stefano, please refer to the below knowledge article which might help you further:

https://help.salesforce.com/articleView?id=000331668&type=1 (https://help.salesforce.com/articleView?id=000331668&type=1)
I found this in some thread and is working.

Use this URL to reset the token and you have to be a user who has access to this though.

Stefano AmentaStefano Amenta
Hi Khan and Apuroop

I tried with pwd + token, but the problem persists.
I tried both with login.salesforce.com and my instance.

User-added image
You are a System Administrator, correct?
Stefano AmentaStefano Amenta
Yes, I'm an Admin.