function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Dan Dodd 3Dan Dodd 3 

sfdx "push failed" message but no debug info just a number to give support

sfdx force:source:push -f
PROJECT PATH                                                     ERROR
force-app/main/default/settings/OrgPreference.settings-meta.xml  An unexpected error occurred. Please include this ErrorId if you contact support: 1137805646-28686 (412474181)
ERROR running force:source:push:  Push failed.

This i the complete error message.

I am pushing into a new scratch org with source that was working yesterday's expired scratch org.

Khan AnasKhan Anas (Salesforce Developers) 
Hi Dan,

Greetings to you!

It was a bug in an earlier version of CLI, although it is fixed in latest SFDX CLI version:

Try to update Salesforce CLI using below command:
sfdx update

If updating SFDX CLI does not resolve the issue, the workaround is to add --json flag to the push command, it usually displays all errors in JSON format.

sfdx force:source:push -f --json

You can also monitor deployments that are in progress, check which deployments are waiting for execution, and view the results of completed deployments on the Deployment Status page from Salesforce Setup.

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Dan Dodd 3Dan Dodd 3
Thanks for the reply, 
While it did update a minor version it did not solve the issue. 
--json help show me the offending files but did not solve the issue.
I tried a few things that also did not solve the issue.
Then removing the file that it called out as having an unknown
error : OrgPreferenceSettings